Bug 739662 - gtk-window-decorator doesn't work on NVIDIA quad monitor setups.
Summary: gtk-window-decorator doesn't work on NVIDIA quad monitor setups.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 18:29 UTC by Ted
Modified: 2012-08-07 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 16:48:34 UTC


Attachments (Terms of Use)
xorg.conf (1.75 KB, application/octet-stream)
2011-09-19 18:43 UTC, Ted
no flags Details

Description Ted 2011-09-19 18:29:54 UTC
Description of problem:
Note:  Everything here worked reasonably well with emerald before the compiz 0.9.5 update.

Since Emerald is no longer an option with Compiz, GTK Window Decorator should be fixed so that it will work with setups that have more than 2 monitors.  If you only have 2 monitors to test with, try disabling twinview and you will probably get similar results.

The first major problem that I've encountered is that when the WM launches it only starts on desktop 0.0 and doesn't appear to be multi desktop aware.  To work around it, I fire off a shell script that looks something like this on startup:

----

# Wait for the desktop to settle
sleep 15s

export DISPLAY=:0.1
gtk-window-decorator --replace &
sleep 3s
export DISPLAY=:0.0
gtk-window-decorator

----

This gets me compiz in a semi-usable state on the top and bottom displays.  Unfortunately, there seem to be some pretty annoying bugs.  The first and most severe is that compiz will only allow me to type in the last monitor that the mouse was in until I switch windows back and forth on the current monitor.  The easiest way to reproduce this problem is to open a thunderbird session on the top desktop and a firefox session on the bottom monitor and start typing.  It sometimes works correctly with other apps, but it screws up every time with thunderbird / firefox (I have click to focus disabled if it makes a difference).  This problem makes the desktop completely unusable as you never are quite sure what window you may be typing in. 

I can no longer highlight text in terminal windows.

The next problem that I noticed is that "shade" mode on the windows is completely broken.  Press ctrl-alt-s on any window and it go into a shaded state, then pop back into an empty window that you can't interact with at all.  I don't think this error is specific to quad monitors.

Click to raise appears to be broken in weird ways now as well.  If you open a terminal for example, and another random app, such as the file manager, clicking on the terminals header is the only way to raise it if it is under the file manager.

I've also noticed that the shelf plugin no longer works.  If you put a window in the shelf mode, you can no longer interact with it at all.  Can't click it, can't move it, can't take it out of shelf mode without killing compiz.

I've been using all of this stuff for at least 6 years now and it has always had bugs here and there but it usually doesn't bother me that much.  I like compiz and find it enhances my productivity, but it's just totally broken now.


Version-Release number of selected component (if applicable):
xfce4-session-4.8.1-5.fc15.x86_64
compiz-0.9.5.0-3.fc15.x86_64
xorg-x11-server-Xorg-1.10.4-1.fc15.x86_64
xorg-x11-drv-nvidia-280.13-1.fc15.x86_64


How reproducible:
Always (I have tested this on 3 different computers with similar setups)


Steps to Reproduce:
1. Install an NVIDIA Quattro card or 2 nvidia cards
2. Configure X using the included sample config and current nvidia proprietary driver
3. Despair.
  
Actual results:
A buggy broken desktop that can't be used.

Expected results:
A beautiful functional desktop that enhances productivity

Additional info:
A sample xorg.conf file is attached that reproduces it easily.

Comment 1 Ted 2011-09-19 18:43:21 UTC
Created attachment 523886 [details]
xorg.conf

Comment 2 leigh scott 2011-09-19 19:40:02 UTC
I only have a single monitor so I'm unable to test multi screen setups.

How are you starting compiz?, fusion-icon IMO is the best way.
Also you should use the gconf backend for compiz.

Comment 3 Ted 2011-09-19 20:07:53 UTC
I use fusion-icon to start compiz.  I haven't used gconf for a backend in a long time.  I tried turning it on, but I haven't seen any improvement.

Comment 4 Fedora End Of Life 2012-08-07 16:48:36 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.