Bug 73977 - Does not work when installed with an umask of 077 and messes filesystem
Summary: Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 16:33 UTC by Enrico Scholz
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 11:18:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:299 normal SHIPPED_LIVE Updated sendmail packages 2004-09-01 04:00:00 UTC

Description Enrico Scholz 2002-09-13 16:33:09 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/include/libmilter /usr/include/libmilter/mfapi.h
| file /usr/include/libmilter is not owned by any package
| sendmail-devel-8.12.5-5


Version-Release number of selected component (if applicable):

sendmail-devel-8.12.5-5


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that sendmail-devel is uninstalled completely
   (rm -rf /usr/include/libmilter)
3. rpm -U sendmail-devel-8.12.5-5.i386.rpm
4. ls -l /usr/include/libmilter
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e sendmail-devel-8.12.5-5

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 17:46 /usr/include/libmilter
* files can not be found/read at 5 and
* /usr/include/libmilter still exists after 6.

Comment 1 Thomas Woerner 2004-06-14 11:18:35 UTC
Fixed in rawhide in rpm sendmail-8.2.11-5 or newer.

Comment 2 Jay Turner 2004-09-02 02:55:22 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-299.html



Note You need to log in before you can comment on or make changes to this bug.