Bug 739789 - Deleting a VDB from inventory does not remove it
Summary: Deleting a VDB from inventory does not remove it
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Inventory
Version: 3.0.0
Hardware: Unspecified
OS: Linux
high
medium vote
Target Milestone: ---
: ---
Assignee: Pavel Kralik
QA Contact: Mike Foley
URL:
Whiteboard:
: SOA-3502 (view as bug list)
Depends On:
Blocks: rhq42
TreeView+ depends on / blocked
 
Reported: 2011-09-20 03:06 UTC by Joel Tosi
Modified: 2016-10-05 23:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-07 19:29:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-3502 Major Closed Deleting a VDB from inventory does not remove it 2015-10-28 00:52:43 UTC

Description Joel Tosi 2011-09-20 03:06:23 UTC
Using JON 2.4, deleting a VDB through JON GUI inventory removes the vdb from the EDS instance, but does not remove it from inventory.  Instead, it shows the vdb as unavailable.

How reproducible:


Steps to Reproduce:
1. Deploy a vdb to EDS
2. Have agent report vdb to JON, verify in GUI
3. In JON inventory, delete the vdb
  
Actual results:
VDB is removed from physical server but remains in JON inventory, just as disabled.  It remains there even after running 'discovery -f' from the agent console.

Expected results:
VDB is removed from physical server and removed from JON inventory.

Additional info:

Comment 1 Charles Crouch 2011-10-06 15:03:32 UTC
Assigning to Len to retest on JON3

Comment 2 Charles Crouch 2011-10-07 20:09:48 UTC
Assigning to Pavel, via Len, to verify if this is still an issue with the latest version of the plugins and JON3

Comment 3 Pavel Kralik 2011-10-19 13:28:42 UTC
Tested with JON 3.0.0 BETA3, PostgreSQL 8.4.8, OpenJDK 1.6.0, SOA-P/EDS 5.1.0.GA

The VDB deleted from JON is removed physically and from JON inventory too.

Comment 4 Heiko W. Rupp 2011-10-19 13:33:03 UTC
Moving to ON_QA now that Pavel says it is ok.

Comment 5 Van Halbert 2012-01-24 18:33:26 UTC
*** Bug 781020 has been marked as a duplicate of this bug. ***

Comment 6 Mike Foley 2012-02-07 19:29:30 UTC
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Comment 7 Mike Foley 2012-02-07 19:30:17 UTC
marking VERIFIED BZs to CLOSED/CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.