Bug 739796 - subscription-manager gui "Certificate" column and values do not match the cli list --installed
Summary: subscription-manager gui "Certificate" column and values do not match the cli...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-20 04:16 UTC by John Sefler
Modified: 2013-01-10 10:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:24:28 UTC


Attachments (Terms of Use)
proposed column and value changes for "Certificate" (144.14 KB, image/png)
2011-09-20 04:16 UTC, John Sefler
no flags Details
verified column and value changes for "Certificate" (98.43 KB, image/png)
2011-09-23 19:36 UTC, John Sefler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-09-20 04:16:00 UTC
Created attachment 523946 [details]
proposed column and value changes for "Certificate"

Description of problem:
For the sake of parity and clearer values (in my opinion), I think the "Certificate" column on the "My Installed Software" tab and its values should be changed as follows:

Certificate          =>  Status
-----------              -----------
Missing              =>  Not Subscribed
Valid                =>  Subscribed
Valid                =>  Partially Subscribed     (when yellow)
Future Subscription  =>  Future Subscription      (this one already matches)
Expired?             =>  Expired?                 (I don't recall these values)

Are there other cases that I missed?

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.9-1.git.26.e7a7723.el6.x86_64

Comment 1 James Bowes 2011-09-20 15:44:06 UTC
Fixed in RHEL6.2 dd9a8ad9f8442c1f4508ca9ddb53953822ce732e
and master b4b9fc5ab05603473cd77f186c910167b0a2736d

Comment 3 John Sefler 2011-09-23 19:36:59 UTC
Created attachment 524677 [details]
verified column and value changes for "Certificate"

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.11-1.el6.x86_64

All of the requested string changes were made to the GUI so as to bring the CLI list --installed verbage closer in sync with the GUI "My Installed Software" tab.

Also verified (but not shown) that the status of "Expired" is used in both the CLI and GUI.

Comment 4 errata-xmlrpc 2011-12-06 17:24:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.