Bug 73982 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
http://www.tu-chemnitz.de/~ensc/dirch...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 12:34 EDT by Enrico Scholz
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-18 06:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 12:34:01 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/xemacs/mule-packages /usr/lib/xemacs/mule-packages/etc/app-defaults/de/Emacs
| file /usr/lib/xemacs/mule-packages is not owned by any package
| xemacs-21.4.8-14


Version-Release number of selected component (if applicable):

xemacs-21.4.8-14


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that xemacs is uninstalled completely
   (rm -rf /usr/lib/xemacs/mule-packages)
3. rpm -U xemacs-21.4.8-14.i386.rpm
4. ls -l /usr/lib/xemacs/mule-packages
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e xemacs-21.4.8-14

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 18:31 /usr/lib/xemacs/mule-packages
* files can not be found/read at 5 and
* /usr/lib/xemacs/mule-packages still exists after 6.
Comment 1 Jens Petersen 2002-11-12 01:45:44 EST
Thank you very much for the report.  Should be fixed in the next
package release.
Comment 2 Jens Petersen 2002-11-12 09:45:30 EST
xemacs-21.4.10-1 is the package.
Comment 3 Jens Petersen 2002-12-18 06:49:28 EST
(closing fixed)

Note You need to log in before you can comment on or make changes to this bug.