Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 739843 - iscsiadm discovery cannot get correct iface information at first run
iscsiadm discovery cannot get correct iface information at first run
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.1
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Andy Grover
Storage QE
:
Depends On:
Blocks: 767187 903130
  Show dependency treegraph
 
Reported: 2011-09-20 04:12 EDT by Gris Ge
Modified: 2013-01-23 04:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Consequence: iSCSI discovery via a TOE (TCP Offload Engine) interface fails when the iscsiadm -m iface has never been executed. Cause: This is due to the iscsiadm -m discovery command not checking interface settings while the iscsiadm -m iface does. Fix: iscsiadm will try to create the default ifaces when it cannot fine one passed in. Result: Users do not have to run the extra iscsiadm -m iface command before running a command that operates on a iface.
Story Points: ---
Clone Of:
: 844427 903130 (view as bug list)
Environment:
Last Closed: 2012-06-20 10:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0957 normal SHIPPED_LIVE iscsi-initiator-utils bug fix and enhancement update 2012-06-19 16:59:34 EDT

  None (edit)
Description Gris Ge 2011-09-20 04:12:46 EDT
Description of problem:

If perfrom iscsi discovery via TOE card right after iscsi-initiator-utils installed, iscsiadm will fail with iface not found issue.

=====
[root@storageqe-02 ~]# iscsiadm -m discovery -t st -p
na3170b.lab.bos.redhat.com \
> -I "be2iscsi.00:00:c9:a0:e9:0b"
Starting iscsid:                                           [  OK  ]
iscsiadm: Could not read iface info for be2iscsi.00:00:c9:a0:e9:0b. Make
sure a iface config with the file name and iface.iscsi_ifacename
be2iscsi.00:00:c9:a0:e9:0b is in /var/lib/iscsi/ifaces.

[root@storageqe-02 ~]# iscsiadm -m discovery -t st -p
na3170b.lab.bos.redhat.com -I "be2iscsi.00:00:c9:a0:e9:0b"
iscsiadm: Could not read iface info for be2iscsi.00:00:c9:a0:e9:0b. Make
sure a iface config with the file name and iface.iscsi_ifacename
be2iscsi.00:00:c9:a0:e9:0b is in /var/lib/iscsi/ifaces.
[root@storageqe-02 ~]# iscsiadm -m discovery -t st -p
na3170b.lab.bos.redhat.com -I "be2iscsi.00:00:c9:a0:e9:0b"
iscsiadm: Could not read iface info for be2iscsi.00:00:c9:a0:e9:0b. Make
sure a iface config with the file name and iface.iscsi_ifacename
be2iscsi.00:00:c9:a0:e9:0b is in /var/lib/iscsi/ifaces.
[root@storageqe-02 ~]# iscsiadm -m iface
default tcp,<empty>,<empty>,<empty>,<empty>
iser iser,<empty>,<empty>,<empty>,<empty>
be2iscsi.00:00:c9:a0:e9:09
be2iscsi,00:00:c9:a0:e9:09,<empty>,<empty>,<empty>
be2iscsi.00:00:c9:a0:e9:0b
be2iscsi,00:00:c9:a0:e9:0b,<empty>,<empty>,<empty>
[root@storageqe-02 ~]# iscsiadm -m discovery -t st -p
na3170b.lab.bos.redhat.com -I "be2iscsi.00:00:c9:a0:e9:0b"
10.16.41.222:3260,1001 iqn.1992-08.com.netapp:sn.151753773
10.16.43.127:3260,1002 iqn.1992-08.com.netapp:sn.151753773
=====

Work around: execute "iscsiadm -m iface" before discovery

Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.872-26.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install iscsi-initiator-utils on server with iSCSI TOE card.
2. Perform disovery like this:
iscsiadm -m discovery -t st -p \
na3170b.lab.bos.redhat.com -I "be2iscsi.00:00:c9:a0:e9:0b"
3. discovery will failed if "iscsiadm -m iface" not execute before.
  
Actual results:
discovery failed with "iface not found" error

Expected results:
discovery correctly finished.

Additional info:
"iscsiadm -m iface" will check and setup correct iface. this should also be execute before discovery.
Comment 4 Caspar Zhang 2011-09-29 05:29:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    "iscsiadm -m discovery" doesn't check iface settings. But "iscsiadm -m iface" does.

Consequence
    iscsi discovery via TOE iface will failed if "iscsiadm -m iface" has never been executed.

Workaround
    run "iscsiadm -m iface" at least once after iscsi-initiator-uitls installed. Once iface setting been updated, future discovery could perform without any error.

Result
    This bug only affected user who use hard-coded TOE iface for discovery. Normally, user needs to use "iscsiadm -m iface" to check the interface name, then discovery. Hence normal user will not affected.
    This bug only happen if "iscsiadm -m iface" has never been executed.
Comment 5 Martin Prpič 2011-09-29 06:00:12 EDT
Note added to the Storage and File Systems section in the Technical Notes
Comment 6 Martin Prpič 2011-09-29 06:00:12 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,12 +1 @@
-Cause
+iSCSI discovery via a TOE (TCP Offload Engine) interface fails when the iscsiadm -m iface has never been executed. This is due to the iscsiadm -m discovery command not checking interface settings while the iscsiadm -m iface does. To work around this issue, run the iscsiadm -m iface command at least once after installing the iscsi-initiatio-utils package. Once the interface setting is updated, discoveries are performed with no errors.-    "iscsiadm -m discovery" doesn't check iface settings. But "iscsiadm -m iface" does.
-
-Consequence
-    iscsi discovery via TOE iface will failed if "iscsiadm -m iface" has never been executed.
-
-Workaround
-    run "iscsiadm -m iface" at least once after iscsi-initiator-uitls installed. Once iface setting been updated, future discovery could perform without any error.
-
-Result
-    This bug only affected user who use hard-coded TOE iface for discovery. Normally, user needs to use "iscsiadm -m iface" to check the interface name, then discovery. Hence normal user will not affected.
-    This bug only happen if "iscsiadm -m iface" has never been executed.
Comment 8 Mike Christie 2012-03-06 16:38:20 EST
*** Bug 800361 has been marked as a duplicate of this bug. ***
Comment 10 Mike Christie 2012-03-22 05:30:15 EDT
Fixed in iscsi-initiator-utils-6.2.0.872-37.el6.
Comment 12 Bruno Goncalves 2012-03-23 06:26:36 EDT
It has been fixed on iscsi-initiator-utils-6.2.0.872-38.el6.

reproduced the bug on iscsi-initiator-utils-6.2.0.872-36.el6

[root@storageqe-01 ~]# rpm -q iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.872-36.el6.x86_64
[root@storageqe-01 ~]# modprobe bnx2i
[root@storageqe-01 ~]# iscsiadm -m discovery -t st -p na3170b.lab.bos.redhat.com -I bnx2i.00:10:18:88:e7:ff -I bnx2i.00:10:18:88:e7:fd
iscsiadm: Could not read iface info for bnx2i.00:10:18:88:e7:ff. Make sure a iface config with the file name and iface.iscsi_ifacename bnx2i.00:10:18:88:e7:ff is in /var/lib/iscsi/ifaces.
[root@storageqe-01 ~]# iscsiadm -m iface
[root@storageqe-01 ~]# iscsiadm -m discovery -t st -p na3170b.lab.bos.redhat.com -I bnx2i.00:10:18:88:e7:ff -I bnx2i.00:10:18:88:e7:fd
iscsiadm: Please set the iface.ipaddress for iface bnx2i.00:10:18:88:e7:ff, then retry the login command.

-------
rpm -q iscsi-initiator-utilsiscsi-initiator-utils-6.2.0.872-38.el6.x86_64
[root@storageqe-01 ~]# modprobe bnx2i
[root@storageqe-01 ~]# iscsiadm -m discovery -t st -p na3170b.lab.bos.redhat.com -I bnx2i.00:10:18:88:e7:ff -I bnx2i.00:10:18:88:e7:fd
iscsiadm: Please set the iface.ipaddress for iface bnx2i.00:10:18:88:e7:ff, then retry the login command.

Note: this error message to set ipaddress is just because it is needed to configure the IP address on bnx2i drive before running the discovery, but the discovery command was able to read the iface info, therefore this bug is fixed.
Comment 13 Mike Christie 2012-05-01 23:51:51 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,4 @@
-iSCSI discovery via a TOE (TCP Offload Engine) interface fails when the iscsiadm -m iface has never been executed. This is due to the iscsiadm -m discovery command not checking interface settings while the iscsiadm -m iface does. To work around this issue, run the iscsiadm -m iface command at least once after installing the iscsi-initiatio-utils package. Once the interface setting is updated, discoveries are performed with no errors.+Consequence: iSCSI discovery via a TOE (TCP Offload Engine) interface fails when the iscsiadm -m iface has never been executed.
+Cause: This is due to the iscsiadm -m discovery command not checking interface settings while the iscsiadm -m iface does.
+Fix: iscsiadm will try to create the default ifaces when it cannot fine one passed in.
+Result: Users do not have to run the extra iscsiadm -m iface command before running a command that operates on a iface.
Comment 14 errata-xmlrpc 2012-06-20 10:49:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0957.html

Note You need to log in before you can comment on or make changes to this bug.