Bug 739867 - lvm refusing to quit
lvm refusing to quit
Status: CLOSED DUPLICATE of bug 681582
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 05:20 EDT by Kamil Páral
Modified: 2011-09-20 07:37 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-20 07:37:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2011-09-20 05:20:14 EDT
Description of problem:
I have Fedora 15. Originally everything worked fine. But some time ago there must have been some update that broken the reboot/poweroff capability for me. Every time I try to reboot, the system just hangs. When I use sysrq to send sigterm to all processes, I see a message on system console (not literal):

[lvm] there are still devices being monitored
[lvm] refusing to quit

I have to kill all processes using sysrq to reboot successfully. This happens always.

How I can produce some debug logs to help you fix this issue?

Version-Release number of selected component (if applicable):
lvm2-2.02.84-3.fc15.x86_64

How reproducible:
always
Comment 1 Milan Broz 2011-09-20 07:37:34 EDT
See bug #681582 I think there is test package mentioned there which should help.

*** This bug has been marked as a duplicate of bug 681582 ***

Note You need to log in before you can comment on or make changes to this bug.