Bug 739884 - Delivered examples are not usable with EAP
Summary: Delivered examples are not usable with EAP
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-jca
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: 2.0.4
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 10:33 UTC by Jiri Pechanec
Modified: 2011-09-22 13:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 23:29:46 UTC


Attachments (Terms of Use)
Exception log (27.86 KB, application/octet-stream)
2011-09-20 10:33 UTC, Jiri Pechanec
no flags Details
Proposed qpid-jca-ds.xml (3.35 KB, text/xml)
2011-09-20 12:42 UTC, Jiri Pechanec
no flags Details

Description Jiri Pechanec 2011-09-20 10:33:57 UTC
Created attachment 523998 [details]
Exception log

conf/qpid-jca-ds.xml

1) QpidConnectionFactory contains hard-coded URL to MRG server, it should be dynamic in the same way as for QpidJMS and QpidJMSXA factories.

2) Queue and Topic should be defined using the new configuration, so for example replace
  <mbean code="org.jboss.resource.deployment.AdminObject"
         name="qpid.jca:name=HelloQueue">
     <attribute name="JNDIName">queue/Hello</attribute>
     <depends optional-attribute-name="RARName">jboss.jca:service=RARDeployment,name='@rar.name@'</depends>
     <attribute name="Type">javax.jms.Destination</attribute>
     <attribute name="Properties">
        destinationType=QUEUE
        destinationAddress=amq.direct
     </attribute>
  </mbean>

with
  <mbean code="org.jboss.resource.deployment.AdminObject"
         name="qpid.jca:name=HelloQueue">
     <attribute name="JNDIName">queue/Hello</attribute>
     <depends optional-attribute-name="RARName">jboss.jca:service=RARDeployment,name='qpid-ra-0.10.rar'</depends>
     <attribute name="Type">javax.jms.Destination</attribute>
     <attribute name="Properties">
                destinationAddress=queue.Hello;{create:always,node:{type:queue}}
                destinationType=queue
     </attribute>
  </mbean>

3) run-client throws an exception during EJB invocation
ant -Dbroker.url="amqp://guest:guest@/test?brokerlist='tcp://mrg01.mw.lab.eng.bos.redhat.com:5672'"

     [java] Caused by: javax.transaction.RollbackException: [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] Could not commit transaction.
     [java] 	at com.arjuna.ats.internal.jta.transaction.arjunacore.TransactionImple.commitAndDisassociate(TransactionImple.java:1443)
     [java] 	at com.arjuna.ats.internal.jta.transaction.arjunacore.BaseTransaction.commit(BaseTransaction.java:137)
     [java] 	at com.arjuna.ats.jbossatx.BaseTransactionManagerDelegate.commit(BaseTransactionManagerDelegate.java:75)
     [java] 	at org.jboss.aspects.tx.TxPolicy.endTransaction(TxPolicy.java:170)
     [java] 	at org.jboss.aspects.tx.TxPolicy.invokeInOurTx(TxPolicy.java:87)
     [java] 	at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:190)
     [java] 	at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:102)
     [java] 	at org.jboss.aspects.tx.TxPropagationInterceptor.invoke(TxPropagationInterceptor.java:76)


There is no information in server.log

Comment 1 Jiri Pechanec 2011-09-20 12:42:53 UTC
Created attachment 524029 [details]
Proposed qpid-jca-ds.xml

The file attached could be used as fix for first two issues

Comment 2 Weston M. Price 2011-09-21 23:29:46 UTC
It looks like you may be using an out of date version of the examples. The new RPM that will be delivered contain updates that address these issues. I am going to close this. Please evaluate the new RPM and re-open the bug if necessary.


Note You need to log in before you can comment on or make changes to this bug.