Bug 739903 - Error message can be more appropriate while there exists no such file or directory.
Summary: Error message can be more appropriate while there exists no such file or dire...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: certmonger
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nalin Dahyabhai
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 11:30 UTC by Gowrishankar Rajaiyan
Modified: 2011-12-06 17:37 UTC (History)
5 users (show)

Fixed In Version: certmonger-0.47-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:37:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1708 normal SHIPPED_LIVE certmonger bug fix update 2011-12-06 01:02:28 UTC

Description Gowrishankar Rajaiyan 2011-09-20 11:30:06 UTC
Description of problem:


Version-Release number of selected component (if applicable):
ipa-server-2.1.1-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: request_1027 [negative test] scenario: [ipa-getcert request -k -f]	data: [PemKeyFile negative]
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [11:46:47] ::  cmd=[ipa-getcert request -k /root/request_1027_17027/no.such.pem.key.file. -f /tmp/getcert28551/request_1027_17027.cert.pem]
:: [11:46:47] ::  expect [1], out=[/tmp/tmp.YU4fmfplSR/request_1027.26455.out]
:: [11:46:47] ::  scenario: [ipa-getcert request -k -f]	data: [PemKeyFile negative]
:: [   PASS   ] :: return code matches, now check the message
:: [   FAIL   ] :: error message does not match as expected 

==========  actual  output  ===============
Path "/root/request_1027_17027" is not a directory.
============== end of output ==============

  
Actual results:
Path "/root/request_1027_17027" is not a directory.

Expected results:
Path "/root/request_1027_17027": No such file or directory. 

Additional info:

Comment 2 Martin Kosek 2011-09-20 11:40:11 UTC
ipa-getcert is owned by certmonger:

# rpm -qf `which ipa-getcert`
certmonger-0.45-1.fc15.1.x86_64

Fixing the BZ component.

Comment 3 Nalin Dahyabhai 2011-09-20 18:12:57 UTC
We're going to handle this one a bit later, I think.

Comment 4 Nalin Dahyabhai 2011-09-27 19:43:01 UTC
Already respinning for bug #741262, so proposing we do this one, too.

Comment 6 Kaleem 2011-10-03 08:24:16 UTC
Verified.

RHEL Version:
=============
[root@dhcp201-220 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.2 Beta (Santiago)

Certmonger Version:
==================
[root@dhcp201-220 ~]# rpm -q certmonger 
certmonger-0.48-1.el6.x86_64
[root@dhcp201-220 ~]#

Steps used to verify:
=====================
(1)Install certmonger 
[root@dhcp201-220 ~]# yum install certmonger -y
Loaded plugins: product-id, subscription-manager
.
.
.
Installed products updated.
Installed:
  certmonger.x86_64 0:0.48-1.el6                                                                    [root@dhcp201-220 ~]#

(2)start certmonger service

[root@dhcp201-220 ~]# service certmonger start
Starting certmonger:                                       [  OK  ]
[root@dhcp201-220 ~]#

(3)Generate a cert request with non-existent storage (either NSS db or files)

(a)Non-existent NSS db
[root@dhcp201-220 ~]# getcert request -d /tmp/non-existent/ -n Test 
Path "/tmp/non-existent": No such file or directory.

(a)Non-existent files
[root@dhcp201-220 ~]# getcert request -k /tmp/non-existent/tmp.key -f /tmp/non-existent/tmp.pem 
Path "/tmp/non-existent": No such file or directory.
[root@dhcp201-220 ~]#

Result:
=======
Now, proper error message "No such file or directory." is displayed.

Comment 7 errata-xmlrpc 2011-12-06 17:37:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1708.html


Note You need to log in before you can comment on or make changes to this bug.