Bug 739907 - [virt-manager]New grab key combination does not work.
Summary: [virt-manager]New grab key combination does not work.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 11:33 UTC by Daisy Wu
Modified: 2014-07-06 19:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-30 02:52:17 UTC


Attachments (Terms of Use)
debug info (5.84 KB, text/plain)
2011-09-27 09:11 UTC, Daisy Wu
no flags Details

Description Daisy Wu 2011-09-20 11:33:42 UTC
Description of problem:
New grab key combination does not work.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-11.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.185.el6
kernel-2.6.32-193.el6

How reproducible:
always

Steps to Reproduce:
1. Make sure have an existing guest in your host.
2. Launch virt-manager: #virt-manager.
3. Click Edit->Preference on Virtual Machine Manager window.
4. Click VM Details tab on Preference window.
5. Press "Change" button.
6. Press new grab key combination on the keyboard such as(alt_R + ctrl_R). Then press OK button.
7. Open VM and show the graphical console to login the vm. Open vm's terminal.
8. Click "alt_R + ctrl_R" on the keyboard.
  
Actual results:
New grab key combination does not work, still need to press old setting "alt_L + ctrl_L" to release pointer.

Expected results:
New grab key combination should work, pointer release from guest to host.

Additional info:

Comment 2 Cole Robinson 2011-09-26 20:38:50 UTC
Hmm, I can't reproduce.

What guest OS is this?
If the guest is using a tablet pointer, does removing it make any difference?
Spice or VNC graphics? Can you test both?
Is it specific to the key combination you chose? How about something like ctrl+alt+s?
If you run virt-manager --debug and reproduce, any suspicious error messages?

Comment 3 Daisy Wu 2011-09-27 07:57:23 UTC
1. Guest OS: rhel5.7
2. Guest is not using a tablet pointer.
3. Only VNC graphics hit this issue, if remove the VNC graphics and add new Spice graphics, restart the guest, grab key (alt_R + ctrl_R) works well.
4. It isn't specific to the key combination I chose. "ctrl+alt+s" hit the same issue.
5. No suspicious error messages displayed by virt-manager --debug.

Comment 4 Daisy Wu 2011-09-27 09:11:27 UTC
Created attachment 525060 [details]
debug info

Comment 5 RHEL Product and Program Management 2011-10-07 16:11:41 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Cole Robinson 2011-10-13 21:01:46 UTC
I think the issue here is that we don't change the keygrab combination for an existing VNC display. Not urgent for 6.2 though so deferring to 6.3

Comment 8 Cole Robinson 2011-12-09 22:19:52 UTC
Not urgent, and given reduced capacity for virt-manager/virtinst, just moving
this to the upstream tracker.


Note You need to log in before you can comment on or make changes to this bug.