Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 739949 - Openswan net-to-net not work with unencrypted connection on specific port, when all other connections are encrypt.
Openswan net-to-net not work with unencrypted connection on specific port, wh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openswan (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Paul Wouters
Aleš Mareček
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-20 10:20 EDT by David Spurek
Modified: 2015-03-02 00:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1588 normal SHIPPED_LIVE openswan bug fix and enhancement update 2014-10-13 21:39:53 EDT

  None (edit)
Description David Spurek 2011-09-20 10:20:00 EDT
Description of problem:
Testing openswan net to net funcionality.
When all connections are encrypted, funcionality is all right. But if I want unencrypted connection on specific port and all other connections encrypted, the funcionlity is broken.. Encrypted connections are fine, but unencrypted connection on specific port doesn't work.

Version-Release number of selected component (if applicable):
openswan-2.6.32-6.el6

How reproducible:
always

Steps to Reproduce:

I have this test case net topology:
left subnet: 192.168.111.0/24
right subnet: 192.168.100.0/24
middle subnet: 192.168.50.0/24

                   GW-left                             GW-right
     192.168.111.179 | | 192.168.50.5 -----192.168.50.6 | | 192.168.100.212
	             /                ipsec               \
	            /                                      \
	           /                                        \
   192.168.111.81 | |                                       | | 192.168.100.226
     PC-left                                                         PC-right

On GW-left and GW-right I have this:
/etc/ipsec.secrets
: PSK "whatever"

 /etc/ipsec.conf
conn test
        left=192.168.50.5
        right=192.168.50.6
        leftsubnet=192.168.111.0/24
        rightsubnet=192.168.100.0/24
        auto=add
        authby=secret
        type=tunnel
        ike=aes256-md5
        phase2=esp

conn pass
        left=192.168.50.5
        right=192.168.50.6
        leftsubnet=192.168.111.0/24
        rightsubnet=192.168.100.0/24
        auto=add
        authby=secret
        type=passthrough
        ike=aes256-md5
        phase2=esp
        rightprotoport=tcp/30000

On both GW run
ip xfrm state flush
ip xfrm policy flush
service ipsec restart
ipsec auto --route pass
ipsec auto --route test

On PC-right run:
nc -l 192.168.100.226 30000
nc -l 192.168.100.226 20000

On PC-left run:
echo "Hi" | nc -v -w 30 192.168.100.226 30000
echo "Hi" | nc -v -w 30 192.168.100.226 20000
  
Actual results:
Connection on port 30000 fail (nc output is connection timeout)
Connection on port 20000 (or other) is all right and encrypted

Expected results:
Connection on port 30000 pass
Comment 1 RHEL Product and Program Management 2012-05-03 01:00:46 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 2 Paul Wouters 2013-05-17 15:41:43 EDT
This is really the same issue as #742126
Comment 6 Paul Wouters 2014-06-22 15:29:11 EDT
(note a workaround is to specify both ends of the protoport= line, in this case:

    rightprotoport=tcp/30000
    leftprotoport=tcp


But this will be resolved for rhel-6.6 to work without adding the leftprotoport as well.
Comment 9 Paul Wouters 2014-08-08 11:17:20 EDT
A bug was found and fixed in netlink_shunt_eroute() that addresses this issue
Comment 12 errata-xmlrpc 2014-10-14 04:18:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1588.html

Note You need to log in before you can comment on or make changes to this bug.