Bug 739977 - Misleading and confusing error message when syncing repo with bad url
Summary: Misleading and confusing error message when syncing repo with bad url
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 1.0
Assignee: Pradeep Kilambi
QA Contact: Katello QA List
URL:
Whiteboard:
: 761159 (view as bug list)
Depends On:
Blocks: katello-sync-mgmt
TreeView+ depends on / blocked
 
Reported: 2011-09-20 15:27 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-18 21:08:02 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-09-20 15:27:44 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.83-1.git.17.fc6a2f6.fc14.noarch

How reproducible:


Steps to Reproduce:
1. Create custom provider, product
2. Create a repo with url "http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/x86_64/os/" - literally - 'forget' to replace $releasever
3. Sync this repo
  
Actual results:
"The specified repo does not match the specified product"

Expected results:
A better error message, something about that the url gives a 404, or that it's not a valid repo.

Additional info:
Better message from pulp.log: 


RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: . Please verify its path and try again

Comment 1 Mike McCune 2011-12-15 00:32:53 UTC
*** Bug 761159 has been marked as a duplicate of this bug. ***

Comment 2 Jason E. Rist 2012-12-18 21:08:02 UTC
This is no longer an issue - it now says "Cannot retrieve repository metadata (repomd.xml) for repository: . Please verify its path and try again" in the error. (Along with a nice stack trace for debugging purposes.)


Note You need to log in before you can comment on or make changes to this bug.