Bug 739981 - Panel does not update after removing repository
Summary: Panel does not update after removing repository
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-20 15:34 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:57:27 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-09-20 15:34:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.83-1.git.17.fc6a2f6.fc14.noarch

How reproducible:


Steps to Reproduce:
1. Create a custom provider
2. Create a product in that provider
3. Create a repo in that product
4. Select the repo
5. Click "Remove repository"
  
Actual results:
Success notification, but the right panel remains with the repository that was supposedly deleted.  You can close that panel, and then the product panel is shown with the repository still existing.  If you select the repo, you get an error.  You have to navigate back to the product top level to get a fresh page.

Expected results:
After repo delete, right panel refreshes back to products/repos panel, with deleted repo no longer shown.

Additional info:

Comment 1 Brad Buckingham 2011-09-29 00:05:54 UTC
git commit: a70e5cc9e2b44cbdbc106689e01ec1046b5a87fd

Comment 2 Corey Welton 2011-10-07 18:32:32 UTC
QA Verified.

Comment 5 Mike McCune 2013-08-16 18:11:50 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.