Bug 74 - xlock doesn't lock virtual terminals.
Summary: xlock doesn't lock virtual terminals.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xlockmore (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-15 10:45 UTC by Jim Toth
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-11-16 14:29:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Toth 1998-11-15 10:45:48 UTC
If I have my X sesssion locked with xlock, I can get around
this by type Ctl-Alt-F1 (or whatever), hit ^Z on startx, do
a ps, and kill the xlock.

Comment 1 Aleksey Nogin 1998-11-16 14:16:59 UTC
This is not a bug, but a normal behavour. If you want to avoid it, you
should use xdm or something like
startx & ; logout

Alternatively you may choose to use vlock to lock the virtual
terminal.

You may also want to uncomment DontZap option in your XF86Config file
to make sure nobody can kill your X-session using Ctrl-Alt-Bkspace

Comment 2 Preston Brown 1998-11-16 14:29:59 UTC
Not a bug, solution(s) explained well in the previous message.

Comment 3 paolo.saggese 1999-02-04 10:08:59 UTC
> something like
> startx & ; logout

Even better -IMHO- (am I wrong?) is starting the X session by
exec-uting it:

exec startx


Note You need to log in before you can comment on or make changes to this bug.