Bug 740010 - Repository doesn't honor checksum_type
Summary: Repository doesn't honor checksum_type
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-20 16:59 UTC by Jay Dobies
Modified: 2013-09-09 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-24 20:15:29 UTC


Attachments (Terms of Use)

Description Jay Dobies 2011-09-20 16:59:11 UTC
I created a repo with checksum type of "sha1" but the created repo uses sha256. I saw this in the pulp logs, which looks like it's passing sha256 to the createrepo command:

2011-09-20 12:49:26,677 9813:140296952198912: pulp.server.util:INFO: util:445 started repo metadata update: ['createrepo', '--database', '--checksum', 'sha256', '--update', '/var/lib/pulp//repos/test-1']

Here is the sequence I ran:

# pulp-admin repo create --id test-1 --checksum_type=sha1
Successfully created repository [ test-1 ]

# head -10 /var/lib/pulp/repos/test-1/repodata/repomd.xml 
<?xml version="1.0" encoding="UTF-8"?>
<repomd xmlns="http://linux.duke.edu/metadata/repo" xmlns:rpm="http://linux.duke.edu/metadata/rpm">
 <revision>1316537366</revision>
<data type="filelists">
  <checksum type="sha256">7bccf2e93e7be668523676ac7ad6a6ecad75730c3934c42be4733f216dc48b6d</checksum>
  <open-checksum type="sha256">bf9808b81cb2dbc54b4b8e35adc584ddcaa73bd81f7088d73bf7dbbada961310</open-checksum>
  <location href="repodata/7bccf2e93e7be668523676ac7ad6a6ecad75730c3934c42be4733f216dc48b6d-filelists.xml.gz"/>
  <timestamp>1316537366</timestamp>
  <size>175</size>
  <open-size>125</open-size>

Comment 1 Jay Dobies 2011-09-20 17:00:48 UTC
<jdob> i'm not sure I'm necessarily doing a valid test, but it looks like if I pass in sha1, I still get sha256 checksums in the created repo
<jdob> assuming I'm reading this right
<jmatthews> jdob, I was thinking of looking at primary.xml
<jmatthews> looking at an entry for package and seeing what checksum type is there
<jmatthews> and in your pulp.log we may be outputting the createrepo command, would you see if it is and paste it?
<jdob> i dont have any packages in the repo yet, that's just the empty repo, i'll try adding one and seeing... lemme check pulp.log now
<jdob> hrm:
<jdob> 2011-09-20 12:49:26,677 9813:140296952198912: pulp.server.util:INFO: util:445 started repo metadata update: ['createrepo', '--database', '--checksum', 'sha256', '--update', '/var/lib/pulp//repos/test-1']
<jdob> i'm guessing that's bad
<jdob> it's ignoring my request to do sha1
<jmatthews> yeah
<jmatthews> jdob, btw your test looks sane with repomd.xml, it should say checksum type=sha1
<jdob> jmatthews: ok, thanks for the sanity check... it felt like that should be the case but I wasnt entirely sure
<jmatthews> so you can ignore my comment about checking primary.xml
<jdob> gotcha

Comment 2 Pradeep Kilambi 2011-09-20 17:23:58 UTC
looks like this was a regression. The checksum is taken into account everywhere else except on init repo

fixed! commit 3d7e8ce42909b3652b36e7db9e2b0665d2194a48

$ sudo pulp-admin repo create --id=foo12345 --checksum_type=sha1
Successfully created repository [ foo12345 ]


$ cat /var/lib/pulp/repos/foo12345/repodata/repomd.xml |grep type
<data type="filelists">
  <checksum type="sha1">994e7bbc878f751cd7c57050aebe1a957f3081a8</checksum>
  <open-checksum type="sha1">fc538a9a01c87202118de7718863e43aef4b8f0f</open-checksum>
<data type="primary">
  <checksum type="sha1">57481448dd03102e2c741522a5b310ab019b43e3</checksum>
  <open-checksum type="sha1">623cb93e72dc46813e3a26a9e3d4436ea8752d06</open-checksum>
<data type="primary_db">
  <checksum type="sha1">a2868e11c315c07f15bc5a8966579f7b34a5a909</checksum>
  <open-checksum type="sha1">619187d9e9c7b5f3121553c554770f5d578fcba7</open-checksum>
<data type="other_db">
  <checksum type="sha1">9316995a4e0bda2e99ee54e09bdbb71d9f30aa30</checksum>
  <open-checksum type="sha1">62fae5f82aa9e9e82fcd184a2037db7b1e814a41</open-checksum>
<data type="other">
  <checksum type="sha1">ded9c108d1005d077ae6d79a14eebbc81063286b</checksum>
  <open-checksum type="sha1">672a396261e07818e0594d56e9c31832320a355c</open-checksum>
<data type="filelists_db">
  <checksum type="sha1">5e09829c2b95efb508ecbc91b2c6d30dc3a97607</checksum>
  <open-checksum type="sha1">d6acea08cf3d34e1d84f2261a1bf4dffcd5645e7</open-checksum>

Comment 3 Jeff Ortel 2011-09-21 21:15:38 UTC
build: 0.233

Comment 4 Preethi Thomas 2011-09-22 18:26:08 UTC
[root@katello-test ~]# rpm -q pulp
pulp-0.0.233-1.el6.noarch
[root@katello-test ~]# 

[root@katello-test ~]# pulp-admin repo create --id=foo12345 --checksum_type=sha1
Successfully created repository [ foo12345 ]

[root@katello-test ~]#  cat /var/lib/pulp/repos/foo12345/repodata/repomd.xml |grep type
  <data type="other_db">
    <checksum type="sha1">9e25c5da09d913a5a2ec8fd7d6143bb83ce1d876</checksum>
    <open-checksum type="sha1">0d4dc9aed0e151354f778b6b48f8ec55a6ef53cf</open-checksum>
  <data type="other">
    <checksum type="sha1">ded9c108d1005d077ae6d79a14eebbc81063286b</checksum>
    <open-checksum type="sha1">672a396261e07818e0594d56e9c31832320a355c</open-checksum>
  <data type="filelists_db">
    <checksum type="sha1">57e6977be9167945835f17672f76907d69b4711e</checksum>
    <open-checksum type="sha1">1650488ad550e065d1798048964f35da41e44b5b</open-checksum>
  <data type="filelists">
    <checksum type="sha1">994e7bbc878f751cd7c57050aebe1a957f3081a8</checksum>
    <open-checksum type="sha1">fc538a9a01c87202118de7718863e43aef4b8f0f</open-checksum>
  <data type="primary_db">
    <checksum type="sha1">dd1adbae68a58863908b9f37593b657382994655</checksum>
    <open-checksum type="sha1">3795b62ef528813bf92f1959bbe9d46458096def</open-checksum>
  <data type="primary">
    <checksum type="sha1">57481448dd03102e2c741522a5b310ab019b43e3</checksum>
    <open-checksum type="sha1">623cb93e72dc46813e3a26a9e3d4436ea8752d06</open-checksum>
[root@katello-test ~]#

Comment 5 Preethi Thomas 2012-02-24 20:15:29 UTC
Pulp v1.0 is released
Closed Current Release.

Comment 6 Preethi Thomas 2012-02-24 20:17:11 UTC
Pulp v1.0 is released.


Note You need to log in before you can comment on or make changes to this bug.