Bug 740062 - fcoe.py fails to detect FCoE NIC due to extraneous newline character
fcoe.py fails to detect FCoE NIC due to extraneous newline character
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-20 15:57 EDT by Michael Brown
Modified: 2014-09-30 19:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-16.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-29 02:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch against current anaconda master branch (740 bytes, patch)
2011-09-20 15:57 EDT, Michael Brown
no flags Details | Diff

  None (edit)
Description Michael Brown 2011-09-20 15:57:18 EDT
Created attachment 524089 [details]
Patch against current anaconda master branch

Description of problem:

When installing to an FCoE target, anaconda does not automatically identify the FCoE NIC based upon the EDD information.  The problem is a trivial mistake in fcoe.py, fixed by the following patch (attached in full):

-        (key, val) = rc.split("=", 1)
+        (key, val) = rc.strip().split("=", 1)

Without the patch, fcoe.py ends up using "ethX\n" as the interface name instead of "ethX", and so ends up reporting an error "Unknown FCoE NIC found in EDD".

The attached patch has been tested and verified to work.



Version-Release number of selected component (if applicable):

Problem is still present in anaconda git tree master branch at the time of writing.


How reproducible:

Always


Steps to Reproduce:

1. Begin an installation to an FCoE target using FCoE-capable BIOS boot firmware such as iPXE.

2. After clicking on "Specialized Storage Devices", switch to console Ctrl-Alt-F3 and observe the error message:

Unknown FCoE NIC found in EDD: eth0
, ignoring

(note the unexpected extra newline in the middle of the message).

3. Observe that the FCoE initiator has not been created for the NIC, and hence the FCoE target disks are not visible within the installer.

  
Actual results:

Installation to an FCoE target is not possible without manually enabling the FCoE initiator via "Add Advanced Target".


Expected results:

The FCoE NIC should be identified automatically based upon the EDD information, with no need to ever click on "Add Advanced Target".


Additional info:

The attached one-line patch has been tested and verified to fix the problem.
Comment 1 Chris Lumens 2011-09-22 09:44:32 EDT
This looks like a reasonable patch to me.  Ales - you've touched fcoe.py the most, so why don't you look over it and if you like it, apply to master.  Thanks.
Comment 2 Ales Kozumplik 2011-09-26 06:41:07 EDT
yes, this looks reasonable. we apparently haven't discovered it because few people use fcoe in fedora and in rhel they use the GUI.
Comment 3 Ales Kozumplik 2011-09-26 07:27:05 EDT
Patch proposed for a review:
https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00209.html

I will push this to f16 only after it is accepted as a blocker.
Comment 4 Tim Flink 2011-10-03 12:51:41 EDT
Discussed in the 2011-09-30 blocker bug review meeting. Accepted as a Fedora 16 final blocker as it violates the following final release criterion [1]:

The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel).

[1] https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
Comment 5 Ales Kozumplik 2011-10-04 04:42:21 EDT
Fixed by 827abd4515ee5517d6eea902e1e78cca99984d93 (0fd9bd19f45612456e771c437ca348804c05770b on master). 

Michael, thank you for the fix.
Comment 6 Adam Williamson 2011-10-14 14:56:33 EDT
Discussed at 2011-10-14 blocker review meeting. Michael, the fix for this should be in Fedora 16 Final TC1 which will land soon, please re-test and confirm with that. I'll update the bug again when it's available. Thanks!
Comment 7 Adam Williamson 2011-10-24 20:09:26 EDT
TC2 is available with the fix:

http://dl.fedoraproject.org/pub/alt/stage/16.TC2/

can you please test it and confirm that it's fixed? Thanks!
Comment 8 Adam Williamson 2011-10-28 14:54:29 EDT
Fix is also in TC3:

http://dl.fedoraproject.org/pub/alt/stage/16.TC3/

we really need confirmation that this is fixed, but if we don't get any, we'll have to proceed with release on the assumption that it is.
Comment 9 Adam Williamson 2011-10-29 02:40:50 EDT
anaconda 16.24-2 (glibc rebuild) went stable, so CLOSING. Could still do with verification of the fix in TC3 or pending RC1.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.