Bug 74007 - Does not work when installed with an umask of 077 and messes filesystem
Summary: Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ac-archive   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 17:57 UTC by Enrico Scholz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 12:43:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 17:57:54 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/share/aclocal/C++_Support /usr/share/aclocal/C++_Support/ac_cxx_bool.m4
| file /usr/share/aclocal/C++_Support is not owned by any package
| ac-archive-0.5.36-1


Version-Release number of selected component (if applicable):

ac-archive-0.5.36-1


How Reproducible:

100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that ac-archive is uninstalled completely
   (rm -rf /usr/share/aclocal/C++_Support)
3. rpm -U ac-archive-0.5.36-1.noarch.rpm
4. ls -l /usr/share/aclocal/C++_Support
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e ac-archive-0.5.36-1

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 19:53 /usr/share/aclocal/C++_Support
* files can not be found/read at 5 and
* /usr/share/aclocal/C++_Support still exists after 6.

Comment 1 Jens Petersen 2003-02-19 12:41:32 UTC
Thanks for the report.  Should get fixed the next time
I build ac-archive.

Comment 2 Jens Petersen 2003-02-19 12:56:39 UTC
Should be fixed in ac-archive-0.5.39-2.  Please confirm.

Comment 3 Enrico Scholz 2003-02-25 12:43:03 UTC
Fix verified. Thanks


Note You need to log in before you can comment on or make changes to this bug.