This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 74008 - I have seemingly have a corrupted rpm database
I have seemingly have a corrupted rpm database
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 13:59 EDT by Alan Polinsky
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:59:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the messages I get when I try to run up2date (998 bytes, text/plain)
2002-09-13 14:01 EDT, Alan Polinsky
no flags Details

  None (edit)
Description Alan Polinsky 2002-09-13 13:59:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
I have run the db_dump | db_load to rebuild the Packages file, followed by the 
rpm --rebuilddb option It has not helped. I can sucessfully run rpm -qa. I 
cannot upgrade rpm using the install on the original cd because the upgrade 
reports a partition size problem. The disk was initially partioned by Redhat 
7.1. I cannot re-install the entire system, becuase it is my dsl gateway 
machine. The box is an ibm pentium 133.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run up2date, or try to install anything using rpm
2. I get the error
3.
	

Actual Results:  I get an error indicating a problem with the database. I will 
attach a copy of the messages I get.

Expected Results:  Either up2date, or rpm should have allowed the database to 
be updated

Additional info:
Comment 1 Alan Polinsky 2002-09-13 14:01:38 EDT
Created attachment 76084 [details]
the messages I get when I try to run up2date
Comment 2 Adrian Likins 2003-01-20 23:21:44 EST
what is the result of:

rpm -q redhat-release

and:

rpm -q --whatprovides "redhat-release"?


That message basically indicates that up2date is attempting to
determine what release you are running by looking for the package
that provides "redhat-release" and checking it's version number.

If that package isn't installed, or it can't be read, that is
the error message you will get. 
Comment 3 Alan Polinsky 2003-01-21 08:52:06 EST
Someone already answered with the same response. I followed the suggestions and
the machine is now working fine. You can mark the problem as 'resolved'. 

Alan Polinsky

Note You need to log in before you can comment on or make changes to this bug.