Bug 740101 - some icons are displayed incorectly
Summary: some icons are displayed incorectly
Keywords:
Status: CLOSED DUPLICATE of bug 709763
Alias: None
Product: Fedora
Classification: Fedora
Component: tango-icon-theme
Version: 15
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 00:05 UTC by Szymon Gruszczynski
Modified: 2011-12-11 17:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-11 17:49:54 UTC


Attachments (Terms of Use)
screen of tango's bug (37.11 KB, image/png)
2011-09-21 00:05 UTC, Szymon Gruszczynski
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 41069 None None None Never

Description Szymon Gruszczynski 2011-09-21 00:05:23 UTC
Created attachment 524109 [details]
screen of tango's bug

Description of problem:
some icons have black background around them.

Version-Release number of selected component (if applicable):
tango-icon-theme-0.8.90-4.fc15.noarch
tango-icon-theme-extras-0.1.0-5.fc15.noarch

How reproducible:
always

Steps to Reproduce:
1. select "tango icon theme" in icons 
2. click "ok"
3. enjoy
  
Actual results:
icons have black background around them, it should be transparrent
Expected results:
background should be transparrent

Additional info:
http://imageshack.us/photo/my-images/64/sckrgnome.png/
this is when there is gnome-icon-theme enabled. pay attention on "back" icon on firefox /in background/ and on a row of icons on thunar on left side /in foreground/

now- the same in tango
http://imageshack.us/photo/my-images/5/scrtango.png/
as you can see, the "trash" icon /in thunar/ is displayed properly /i.e without black background/.

also, here http://imageshack.us/photo/my-images/16/ssssio.png/ you can see the differences between window opened from within firefox /in attachment area, on browse button/ and "standard one" /i.e. thunar- on foreground/. the icons for "documents, downloads, music, pictures, videos" are different.

Comment 1 Christoph Wickert 2011-09-21 08:26:42 UTC
I can confirm the problem, however I am not sure it's tango-icon-theme's fault.

The black background only appears when an icon gets resized. You can observe this for example in Thunar when you change the size of icons the sidbar in the settings. As long as the icon is not scaled, the background is transparent.

Comment 2 Christoph Wickert 2011-09-21 08:45:08 UTC
Reported upstream to tango-icon-theme at
https://bugs.freedesktop.org/show_bug.cgi?id=41069
Let's see what Jakub thinks about it. Could also be a bug in librsvg.

Comment 3 Szymon Gruszczynski 2011-09-21 09:16:54 UTC
Hi!
thanks for showing interest about that bug.
i'm afraid that that bug exist not only when i resize icons- the screenshots i've linked here were taken on the standard size in thunar, i.e. without any other modifications, just default. also, by some reason, the "trash" icon is displayed correctly /and that icon is a part of tango theme/ - as you can see on first 2 pictures.
what could be a reason for bug showed on link 3?

have a nice day,
Simon

Comment 4 Christoph Wickert 2011-09-21 09:33:50 UTC
(In reply to comment #3)
> thanks for showing interest about that bug.

I'm trying my best...

> i'm afraid that that bug exist not only when i resize icons- the screenshots
> i've linked here were taken on the standard size in thunar, i.e. without any
> other modifications, just default.

The default in Thunar is 36 px while the icon theme only provides 32 px.

> also, by some reason, the "trash" icon is
> displayed correctly /and that icon is a part of tango theme/ - as you can see
> on first 2 pictures.

Well, Fedora/Mist icon themes do include 36 px icons:

$ ls /usr/share/icons/{Fedora,Tango}
/usr/share/icons/Fedora:
16x16  22x22  24x24  256x256  32x32  36x36  48x48  96x96  icon-theme.cache  index.theme  scalable

/usr/share/icons/Tango:
128x128  16x16  22x22  24x24  32x32  48x48  64x64  72x72  96x96  icon-theme.cache  index.theme  scalable

> what could be a reason for bug showed on link 3?

Did you restart Firefox after changing the theme? Keep in mind that Firefox is not using GTK2 or GTK3 to draw it's interface but XUL. XUL only mimics GTK2 but does not support applying all xsettings on demand.

Comment 5 Christoph Wickert 2011-12-11 17:49:54 UTC
I just figured out that this was already reported in bug 709763 and there even is a fix. Stay tuned for an update.

*** This bug has been marked as a duplicate of bug 709763 ***


Note You need to log in before you can comment on or make changes to this bug.