Bug 740103 - Extreme latency during install
Summary: Extreme latency during install
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 00:51 UTC by Christopher Svanefalk
Modified: 2011-09-21 15:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 15:10:53 UTC


Attachments (Terms of Use)

Description Christopher Svanefalk 2011-09-21 00:51:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora 9 in Text Mode, standard set of packages
2. Perform upgrade with preupgrade
3. Boot into upgrade mode
  
Actual results:

Writing this, it has taken the installer close to an hour to get past the stage of retrieving information about the installation. Currently, it is in the dependency check mode of the next stage. There is disc and network activity, but everything goes extremely slowly, and dragging the Dependency Check box around on the screen "wipes out" other screen elements.


Expected results:

Normal speed, such as during a normal install of Fedora.

Additional info:

Running an HP Probook 4510s which usually has no major problems running Fedora or Linux in general.

Comment 1 Christopher Svanefalk 2011-09-21 00:54:13 UTC
I forgot to add the problem description (late night here, sorry): It takes extremely long for the system to go through with the install process, in particular ste steps of gathering information about the installation, and checking for dependencies of selected passages.

Moreover, the reason I was installing from a Fedora 9 base was due to technical problems (my laptop started refusing to boot from USB drives), and hence this was essentially all I had available.

Comment 2 Chris Lumens 2011-09-21 15:10:53 UTC
Upgrading from F9 to F16 is not supported - we only support upgrades from two releases back, I believe.  The reason you're getting a lot of churn there is due to the huge number of packages that have changed and their very large dependency sets.  It simply takes a very long time to process so many package changes.


Note You need to log in before you can comment on or make changes to this bug.