Bug 740120 - [abrt] kernel: [118056.732896] WARNING: at include/net/mac80211.h:3081 rate_control_send_low+0x8b/0x10f [mac80211](): TAINTED ---------W
Summary: [abrt] kernel: [118056.732896] WARNING: at include/net/mac80211.h:3081 rate_c...
Keywords:
Status: CLOSED DUPLICATE of bug 731365
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4201f74a65bea597c740b9e5fb3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 01:41 UTC by Luke Macken
Modified: 2016-09-20 02:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 12:55:18 UTC


Attachments (Terms of Use)

Description Luke Macken 2011-09-21 01:41:10 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=/dev/mapper/vg_vorpalblade-lv_root rd_LUKS_UUID=luks-29b27f25-aec9-429d-82d1-ed512bb04bdb rd_LVM_LV=vg_vorpalblade/lv_root rd_LVM_LV=vg_vorpalblade/lv_swap rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us quiet initcall_debug printk.time=y init=/sbin/bootchartd
comment:        It feels like this issue occurs when large bursts of wireless traffic occur, but I am not certain.
component:      kernel
kernel:         2.6.40.4-5.fc15.x86_64
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         [118056.732896] WARNING: at include/net/mac80211.h:3081 rate_control_send_low+0x8b/0x10f [mac80211]()
time:           Tue Sep 13 16:07:08 2011

backtrace:
:[118056.732896] WARNING: at include/net/mac80211.h:3081 rate_control_send_low+0x8b/0x10f [mac80211]()
:[118056.732904] Hardware name: 4291CL9
:[118056.732910] Modules linked in: tcp_lp vfat fat usb_storage uas fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge 8021q garp stp llc sunrpc cpufreq_ondemand acpi_cpufreq mperf rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec arc4 snd_hwdep snd_seq snd_seq_device snd_pcm btusb iwlagn bluetooth mac80211 uvcvideo videodev xhci_hcd cfg80211 snd_timer iTCO_wdt thinkpad_acpi i2c_i801 media e1000e iTCO_vendor_support snd_page_alloc v4l2_compat_ioctl32 joydev rfkill microcode snd soundcore virtio_net kvm_intel kvm ipv6 xts gf128mul dm_crypt sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[118056.733079] Pid: 23302, comm: kworker/u:2 Tainted: G        W   2.6.40.4-5.fc15.x86_64 #1
:[118056.733086] Call Trace:
:[118056.733109]  [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
:[118056.733122]  [<ffffffff81054cc0>] warn_slowpath_null+0x1a/0x1c
:[118056.733155]  [<ffffffffa0370627>] rate_control_send_low+0x8b/0x10f [mac80211]
:[118056.733187]  [<ffffffffa0408306>] rs_get_rate+0x138/0x215 [iwlagn]
:[118056.733221]  [<ffffffffa03709bb>] rate_control_get_rate+0x86/0x14c [mac80211]
:[118056.733257]  [<ffffffffa0378f2c>] invoke_tx_handlers+0x829/0xe7d [mac80211]
:[118056.733289]  [<ffffffffa03795e5>] ieee80211_tx+0x65/0x90 [mac80211]
:[118056.733320]  [<ffffffffa037976f>] ieee80211_xmit+0x15f/0x16e [mac80211]
:[118056.733334]  [<ffffffff813cf834>] ? __alloc_skb+0x8d/0x133
:[118056.733365]  [<ffffffffa037a1e0>] ieee80211_tx_skb+0x56/0x5e [mac80211]
:[118056.733395]  [<ffffffffa0366f74>] ieee80211_send_delba+0x136/0x145 [mac80211]
:[118056.733424]  [<ffffffffa0368062>] ___ieee80211_stop_rx_ba_session+0xdc/0x10e [mac80211]
:[118056.733436]  [<ffffffff81041325>] ? should_resched+0xe/0x2d
:[118056.733463]  [<ffffffffa03680e5>] __ieee80211_stop_rx_ba_session+0x51/0x68 [mac80211]
:[118056.733490]  [<ffffffffa0367c01>] ? ieee80211_start_tx_ba_cb+0x5b/0xd2 [mac80211]
:[118056.733518]  [<ffffffffa0366ce5>] ieee80211_sta_tear_down_BA_sessions+0x50/0x5d [mac80211]
:[118056.733546]  [<ffffffffa0369be7>] ieee80211_set_disassoc+0xd1/0x1ee [mac80211]
:[118056.733573]  [<ffffffffa0369eb0>] ieee80211_sta_connection_lost+0x45/0x98 [mac80211]
:[118056.733629]  [<ffffffffa036c50a>] ieee80211_sta_work+0x119/0x12c [mac80211]
:[118056.733659]  [<ffffffffa036f003>] ieee80211_iface_work+0x2af/0x2d2 [mac80211]
:[118056.733688]  [<ffffffffa036ed54>] ? ieee80211_teardown_sdata+0xde/0xde [mac80211]
:[118056.733701]  [<ffffffff8106be6c>] process_one_work+0x176/0x2a9
:[118056.733711]  [<ffffffff8106ca05>] worker_thread+0xda/0x15d
:[118056.733722]  [<ffffffff8106c92b>] ? manage_workers+0x175/0x175
:[118056.733731]  [<ffffffff8106c92b>] ? manage_workers+0x175/0x175
:[118056.733740]  [<ffffffff8106fe77>] kthread+0x84/0x8c
:[118056.733751]  [<ffffffff8148f964>] kernel_thread_helper+0x4/0x10
:[118056.733761]  [<ffffffff8106fdf3>] ? kthread_worker_fn+0x148/0x148
:[118056.733770]  [<ffffffff8148f960>] ? gs_change+0x13/0x13

Comment 1 Chuck Ebbert 2011-09-21 12:55:18 UTC

*** This bug has been marked as a duplicate of bug 731365 ***


Note You need to log in before you can comment on or make changes to this bug.