Bug 740158 - [VDSM] vdsm sends wrong host interface tx_rate and rx_rate to rhevm.
Summary: [VDSM] vdsm sends wrong host interface tx_rate and rx_rate to rhevm.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: unspecified
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact:
URL:
Whiteboard: network
Depends On:
Blocks: 739923
TreeView+ depends on / blocked
 
Reported: 2011-09-21 06:46 UTC by Yaniv Lavi
Modified: 2012-09-05 12:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-05 12:16:45 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Yaniv Lavi 2011-09-21 06:46:19 UTC
Description of problem:
vdsm sends large negative values to rhevm instead of percentage in host interface tx_rate and rx_rate.   

Version-Release number of selected component (if applicable):
6.4

How reproducible:
always

Steps to Reproduce:
1.Create setup with several Hosts
2.run on the hosts 'vdsClient -s 0 getVdsStats'
  And check the values (Tx/Rx rate ( '-694.2' / '-470.6') && 'speed': '-1'
  
Actual results:
returns negative on percent stats. the value can be more then -30000 even.

Expected results:
returns positive percent stats.

Additional info:

Comment 2 Dan Kenigsberg 2011-09-21 06:55:43 UTC
please attach vdsm.log, and the output of `vdsClient -s 0 getVdsStats`. Please send me host details (in private), since the problem does not reproduce on hosts that I've seen.

Comment 6 Dan Kenigsberg 2011-09-21 08:41:31 UTC
This bug could have stemmed form kernel reporting negative speed in 

/sys/class/net/eth0/speed

The posted patch prevents this problem, but I cannot be sure until we find a host where this reproduces (and may warrant a separate kernel bug).

http://gerrit.usersys.redhat.com/962

Comment 7 Dan Kenigsberg 2012-09-05 12:16:45 UTC
Please reopen this bug if the following commit did not help, and you have a reproducer.

commit c70c7d02ac4fe513694a47cf0f1263c7e715d888
Author: Dan Kenigsberg <danken@redhat.com>
Date:   Wed Sep 21 11:33:39 2011 +0300

    BZ#740158 netinfo: never report negative speed
    
    Even if, for some reason,
    
        /sys/class/net/eth0/speed
    
    had a negative value, we should not report it as such. It justly
    confuses users.


Note You need to log in before you can comment on or make changes to this bug.