Bug 740212 - Network device scripts over bonding changed after register to rhevm
Summary: Network device scripts over bonding changed after register to rhevm
Keywords:
Status: CLOSED DUPLICATE of bug 531390
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: Kiril Nesenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 09:53 UTC by Guohua Ouyang
Modified: 2014-07-11 00:08 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 07:29:20 UTC


Attachments (Terms of Use)
network scripts (20.00 KB, application/x-gzip)
2011-09-21 09:53 UTC, Guohua Ouyang
no flags Details

Description Guohua Ouyang 2011-09-21 09:53:40 UTC
Created attachment 524175 [details]
network scripts

Description of problem:
Configure nic bonding with two nics using mode 4, after register to rhevm,  one of the bonding nics goes down after register to rhevm,  the content of network scripts are changed, also the content of /proc/net/bonding/bond4.


Version-Release number of selected component (if applicable):
vdsm-4.9-96.1.el6.x86_64
rhev-hypervisor-6.2-0.17.2
rhevm 140.2 

How reproducible:
Always.

Steps to reproduce:
1. Configure nic bonding with two nics using mode 4.
2. Register to rhevm.
3. Drop to shell, run ifconfig to check the network.

Actual results:
one of the bonding nics goes down after register to rhevm,  the content of network scripts are changed, also the content of /proc/net/bonding/bond4.

Expected results:
it should only change the bridge's name to rhevm, others should keep the same before register to rhevm.

Additional info:
Please refer to attachment for the network scripts before and after register to rhevm.

Comment 2 Dan Kenigsberg 2011-09-21 10:32:34 UTC
This seems like a dup of bug 531390. Am I correct?

You can circumvent that issue by pre-defining a bridge called rhevm and connecting it to your bonding device.

Comment 3 Guohua Ouyang 2011-09-22 02:38:13 UTC
(In reply to comment #2)
> This seems like a dup of bug 531390. Am I correct?
> 
> You can circumvent that issue by pre-defining a bridge called rhevm and
> connecting it to your bonding device.

pre-defining a bridge called rhevm over bonding device did not meet this issue,  register to rhevm, all network device's scripts keep the same.

Comment 4 Dan Kenigsberg 2011-09-22 07:29:20 UTC

*** This bug has been marked as a duplicate of bug 531390 ***


Note You need to log in before you can comment on or make changes to this bug.