Bug 740248 - [abrt] meld-1.5.2-1.fc15: filediff.py:720:after_text_insert_text:TypeError: mark should be a GtkTextMark
Summary: [abrt] meld-1.5.2-1.fc15: filediff.py:720:after_text_insert_text:TypeError: m...
Keywords:
Status: CLOSED DUPLICATE of bug 740246
Alias: None
Product: Fedora
Classification: Fedora
Component: meld
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8ef86efc46994747390208d6fb5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 13:04 UTC by Robbin
Modified: 2012-03-06 14:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-06 14:21:33 UTC


Attachments (Terms of Use)

Description Robbin 2011-09-21 13:04:51 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        python /usr/bin/meld .
comment:        I edited files (in meld) while they where beeing diffed.
component:      meld
executable:     /usr/bin/meld
kernel:         2.6.40.4-5.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        meld-1.5.2-1.fc15
reason:         filediff.py:720:after_text_insert_text:TypeError: mark should be a GtkTextMark
time:           Tue Sep 20 14:38:22 2011
uid:            500
username:       ribbones

backtrace:
:filediff.py:720:after_text_insert_text:TypeError: mark should be a GtkTextMark
:
:Traceback (most recent call last):
:  File "/usr/share/meld/meld/filediff.py", line 720, in after_text_insert_text
:    starting_at = buf.get_iter_at_mark(start_mark).get_line()
:TypeError: mark should be a GtkTextMark
:
:Local variables in innermost frame:
:textlen: 294
:self: <FileDiff object at 0x100a410 (meld+filediff+FileDiff at 0x182cd80)>
:it: <GtkTextIter at 0x1a3ab70>
:newtext: '  /* Internal constants used to call the right function in native code */\n  static private final int NEAREST = 1;\n  static private final int NEAREST_HIGHER = 2;\n  static private final int NEAREST_LOWER = 3;\n  static private final int NEXT_LOWER = 4;\n  static private final int NEXT_HIGHER = 5;\n'
:buf: <gtk.TextBuffer object at 0x17a95a0 (GtkTextBuffer at 0x1179710)>
:start_mark: None

Comment 1 Michael Spahn 2012-03-06 14:21:33 UTC

*** This bug has been marked as a duplicate of bug 740246 ***


Note You need to log in before you can comment on or make changes to this bug.