This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 740264 - VNC install boots into runlevel 3
VNC install boots into runlevel 3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-21 09:37 EDT by Kamil Páral
Modified: 2011-09-21 11:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-21 10:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2011-09-21 09:37:26 EDT
Description of problem:
I tried to install Fedora 16 RC1 DVD i686 with updates and updates-testing repositories enabled, all defaults. When doing standard installation, computer correctly starts in runlevel 5. But when doing the same installation over VNC, computer starts in runlevel 3 (/etc/systemd/system/default.target is symlinked to runlevel3.target).

Expected behavior is getting the same configuration as in non-VNC install.

Version-Release number of selected component (if applicable):
anaconda 16.18
systemd-35.1

How reproducible:
always

Steps to Reproduce:
1. https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_VNC
2. boots into runlevel 3, should into 5
Comment 1 Kamil Páral 2011-09-21 09:39:30 EDT
Proposing for Beta blocker:

In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account
https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 2 Chris Lumens 2011-09-21 10:09:10 EDT
A VNC install gets you runlevel 3 by default, so this is not a bug.
Comment 3 Kamil Páral 2011-09-21 11:36:01 EDT
Ouch. Sorry for the noise. I'll amend our test cases to point that out.

Note You need to log in before you can comment on or make changes to this bug.