Bug 740272 - gsettings assertion failure: (process:3918): GLib-CRITICAL **: g_strv_length: assertion `str_array != NULL' failed
Summary: gsettings assertion failure: (process:3918): GLib-CRITICAL **: g_strv_length:...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 743401 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 13:56 UTC by Charles R. Anderson
Modified: 2011-11-04 21:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-04 21:42:07 UTC


Attachments (Terms of Use)

Description Charles R. Anderson 2011-09-21 13:56:48 UTC
Description of problem:

Running gsettings list-recursively prints this error message on the terminal.

Version-Release number of selected component (if applicable):
glib2-2.29.90-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. gsettings list-recursively | grep enabled-extensions
2.
3.
  
Actual results:

>gsettings list-recursively | grep enabled-extensions

(process:3998): GLib-CRITICAL **: g_strv_length: assertion `str_array != NULL' failed
org.gnome.shell enabled-extensions ['places-menu@gnome-shell-extensions.gnome.org', 'temperature@xtranophilist', 'presentationmode@ampad.de']

Expected results:

No assertion.

Additional info:

Comment 1 igor.redhat@gmail.com 2011-10-04 19:37:34 UTC
*** Bug 743401 has been marked as a duplicate of this bug. ***

Comment 2 Matthias Clasen 2011-11-04 21:42:07 UTC
This was fixed in 2.30.1.
Compare https://bugzilla.gnome.org/show_bug.cgi?id=660147


Note You need to log in before you can comment on or make changes to this bug.