Bug 740279 - Unable to send message to PackageKit
Summary: Unable to send message to PackageKit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 14:09 UTC by udo
Modified: 2014-01-21 23:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 17:12:19 UTC


Attachments (Terms of Use)

Description udo 2011-09-21 14:09:52 UTC
Description of problem:
`Unable to send message to PackageKit` at end of `yum update`

Version-Release number of selected component (if applicable):
yum-3.2.29-9.fc15.noarch

How reproducible:
yum update

Steps to Reproduce:
1.
2.
3.
  
Actual results:
(...)
Unable to send message to PackageKit
#

Expected results:
(...)
#

Additional info:
Yes, we disabled packagekit because it logs for no reason, see 
https://bugzilla.redhat.com/show_bug.cgi?id=739076, but when I comfortably run yum from the CLI I did not request any packagekit action, nor do I expect any.
I just want it to update whatever I ask it to.
So this is typically another case where stuff becomes intertwangled for no reason. Ever try to uninstall ntfsprogs on a box that will never see ntfs?
And that is small issue.
Or tried to remove PackageKit?
Dependency-hell ensues.
So why is yum suddenly leaning on PK?
And bothering me with that?

Comment 1 Tim Lauridsen 2011-09-22 17:12:19 UTC
Don't blame yum :) it is PK there is installing a yum plugin there trigger PK when a transaction is complete

yum remove PackageKit-yum-plugin

should fix that


Note You need to log in before you can comment on or make changes to this bug.