Bug 740290 - Restarting clvmd -S is passing every second exclusive lock and option -E is ignored
Summary: Restarting clvmd -S is passing every second exclusive lock and option -E is i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-09-21 14:47 UTC by Zdenek Kabelac
Modified: 2012-06-20 15:00 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.95-1.el6
Doc Type: Bug Fix
Doc Text:
Restart clvmd (options -S) should preserve exclusive locks on restarted cluster node. However the option -E which should pass such exclusive locks has buggy implementation, so exclusive locks were not preserved in cluster after restart. Fix implemented proper support for option -E, so after restart of clvmd, locks should preserve its exclusive state.
Clone Of:
Environment:
Last Closed: 2012-06-20 15:00:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0962 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2012-06-19 21:12:11 UTC

Description Zdenek Kabelac 2011-09-21 14:47:45 UTC
Description of problem:

When clvmd is requested to be restarted with option -S 
It collects exclusive locks it keeps - but only every second one is passed in the internal restart execution call.

Also the option -E for passing exclusive locks is ignored by clvmd and cause exit of the clvmd.


Version-Release number of selected component (if applicable):
lvm2-2.02.87-2.el6

How reproducible:


Steps to Reproduce:
1. Created clustered volume
2. Create  exclusively activated LVs  (lvcreate, lvchange -aye)
3. Restart clvmd -S
  
Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2011-10-07 15:55:51 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 2 Zdenek Kabelac 2011-10-11 10:33:40 UTC
Addressed by upstream commit:

https://www.redhat.com/archives/lvm-devel/2011-September/msg00168.html

Comment 6 Zdenek Kabelac 2012-04-24 13:05:28 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Restart clvmd (options -S) should preserve exclusive locks on restarted cluster node. However the option -E which should pass such exclusive locks has buggy implementation, so exclusive locks were not preserved in cluster after restart.

Fix implemented proper support for option -E, so after restart of clvmd, locks should preserve its exclusive state.

Comment 7 Corey Marthaler 2012-05-14 22:34:07 UTC
Fix verified in the latest rpms. After a restart (-S) the lv active exclusively was only reactivated on the node which it was originally activated on


2.6.32-269.el6.x86_64
lvm2-2.02.95-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
lvm2-libs-2.02.95-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
lvm2-cluster-2.02.95-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
device-mapper-libs-1.02.74-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
device-mapper-event-1.02.74-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
device-mapper-event-libs-1.02.74-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012
cmirror-2.02.95-8.el6    BUILT: Wed May  9 03:33:32 CDT 2012


# NODE 1: lv1 active, lv2 not active
[root@hayes-01 ~]#  lvs -a -o +devices
  LV   VG   Attr     LSize   Devices              
  lv1  VG1  -wi-a--- 100.00m /dev/etherd/e1.1p1(0)
  lv2  VG2  -wi----- 100.00m /dev/etherd/e1.1p2(0)
[root@hayes-01 ~]# clvmd -S
[root@hayes-01 ~]#  lvs -a -o +devices
  LV   VG   Attr     LSize   Devices              
  lv1  VG1  -wi-a--- 100.00m /dev/etherd/e1.1p1(0)
  lv2  VG2  -wi----- 100.00m /dev/etherd/e1.1p2(0)


# NODE 2: lv1 active, lv2 not active
[root@hayes-02 ~]#  lvs -a -o +devices
  LV   VG   Attr     LSize   Devices              
  lv1  VG1  -wi-a--- 100.00m /dev/etherd/e1.1p1(0)
  lv2  VG2  -wi----- 100.00m /dev/etherd/e1.1p2(0)
[root@hayes-02 ~]# clvmd -S
[root@hayes-02 ~]#  lvs -a -o +devices
  LV   VG   Attr     LSize   Devices              
  lv1  VG1  -wi-a--- 100.00m /dev/etherd/e1.1p1(0)
  lv2  VG2  -wi----- 100.00m /dev/etherd/e1.1p2(0)


# NODE 3: lv1 active, lv2 active exclusively
[root@hayes-03 ~]#  lvs -a -o +devices
  LV   VG   Attr     LSize   Devices              
  lv1  VG1  -wi-a--- 100.00m /dev/etherd/e1.1p1(0)
  lv2  VG2  -wi-a--- 100.00m /dev/etherd/e1.1p2(0)
[root@hayes-03 ~]# clvmd -S
[root@hayes-03 ~]#  lvs -a -o +devices
  LV   VG   Attr     LSize   Devices              
  lv1  VG1  -wi-a--- 100.00m /dev/etherd/e1.1p1(0)
  lv2  VG2  -wi-a--- 100.00m /dev/etherd/e1.1p2(0)

Comment 9 errata-xmlrpc 2012-06-20 15:00:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html


Note You need to log in before you can comment on or make changes to this bug.