Bug 740325 - R200 misrenders some mesa demos
Summary: R200 misrenders some mesa demos
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 6.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 679588
Blocks: 842499
TreeView+ depends on / blocked
 
Reported: 2011-09-21 16:19 UTC by Vitezslav Humpa
Modified: 2017-12-06 12:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 679588
Environment:
Last Closed: 2017-12-06 12:42:25 UTC


Attachments (Terms of Use)
spectex HW rendering (120.67 KB, image/png)
2011-09-21 16:22 UTC, Vitezslav Humpa
no flags Details
spectex SW rendering (11.50 KB, image/png)
2011-09-21 16:32 UTC, Vitezslav Humpa
no flags Details

Description Vitezslav Humpa 2011-09-21 16:19:39 UTC
+++ This bug was initially created as a clone of Bug #679588 +++

Description of problem:
R200 misrenders many of the mesa demos.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.14.2-6.el6
ATI Technologies Inc RV200 [Radeon 8500]

How reproducible:
Always

Steps to Reproduce:
1. Run e.g. reflect or spectex (in /usr/lib/mesa)
2. See the output as compared to when run with LIBGL_ALWAYS_SOFTWARE=1

Actual results:
Reflect doesn't seem to be lit
Misrendered ball in spectex
And more with the other demos.

Expected results:
Images are fairly close to identical to the software rendering.

Additional info:
Nothing particular in Xorg log or messages.

See the Fedora bug for example screenshots of reflex rendering. Spectex example will be attached.

Comment 1 Vitezslav Humpa 2011-09-21 16:22:38 UTC
Created attachment 524241 [details]
spectex HW rendering

Comment 2 Vitezslav Humpa 2011-09-21 16:32:17 UTC
Created attachment 524243 [details]
spectex SW rendering

Comment 4 RHEL Product and Program Management 2011-10-07 16:13:56 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 5 Jan Kurik 2017-12-06 12:42:25 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.