Bug 740325 - R200 misrenders some mesa demos
R200 misrenders some mesa demos
Status: NEW
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jerome Glisse
Desktop QE
: Triaged
Depends On: 679588
Blocks: 842499
  Show dependency treegraph
 
Reported: 2011-09-21 12:19 EDT by Vitezslav Humpa
Modified: 2015-09-11 10:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 679588
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spectex HW rendering (120.67 KB, image/png)
2011-09-21 12:22 EDT, Vitezslav Humpa
no flags Details
spectex SW rendering (11.50 KB, image/png)
2011-09-21 12:32 EDT, Vitezslav Humpa
no flags Details

  None (edit)
Description Vitezslav Humpa 2011-09-21 12:19:39 EDT
+++ This bug was initially created as a clone of Bug #679588 +++

Description of problem:
R200 misrenders many of the mesa demos.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.14.2-6.el6
ATI Technologies Inc RV200 [Radeon 8500]

How reproducible:
Always

Steps to Reproduce:
1. Run e.g. reflect or spectex (in /usr/lib/mesa)
2. See the output as compared to when run with LIBGL_ALWAYS_SOFTWARE=1

Actual results:
Reflect doesn't seem to be lit
Misrendered ball in spectex
And more with the other demos.

Expected results:
Images are fairly close to identical to the software rendering.

Additional info:
Nothing particular in Xorg log or messages.

See the Fedora bug for example screenshots of reflex rendering. Spectex example will be attached.
Comment 1 Vitezslav Humpa 2011-09-21 12:22:38 EDT
Created attachment 524241 [details]
spectex HW rendering
Comment 2 Vitezslav Humpa 2011-09-21 12:32:17 EDT
Created attachment 524243 [details]
spectex SW rendering
Comment 4 RHEL Product and Program Management 2011-10-07 12:13:56 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.