Bug 740340 - Upload Subscription Manifest: Hitting submit w/o actually uploading a file returns uncaught error
Summary: Upload Subscription Manifest: Hitting submit w/o actually uploading a file re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-21 17:16 UTC by Corey Welton
Modified: 2013-08-16 18:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:57:38 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-21 17:16:37 UTC
Description of problem:

When user hits the Upload button without having actually chosen a file, an error is thrown to the screen that probably should be caught and returned to the user in a friendly manner.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Content > Providers > Red Hat > Subscriptions
2.  Hit the Upload button prior to ever trying to provide an actual file.
3.  View results
  
Actual results:
Error message: 
Missing partial providers/subscriptions with {:formats=>[:js, "application/ecmascript", "application/x-ecmascript", "*/*"], :locale=>[:en, :en], :handlers=>[:builder, :haml, :rjs, :erb, :rhtml, :rxml]} in view paths "/usr/share/katello/app/views"

Expected results:
Caught error message.

Additional info:

Comment 1 Brad Buckingham 2011-10-04 18:35:46 UTC
commit: 6b29b75e546ec0d4d83a8c151c735763c63b1ccf

Updated to generate a proper error notification if user clicks 'Upload' without
providing a file to upload.

The notice states:
Subscription Manifest must be specified on upload.

Comment 2 Corey Welton 2011-10-25 03:45:15 UTC
QA Verified

Comment 5 Mike McCune 2013-08-16 18:02:21 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.