Bug 740359 - SELinux is preventing /usr/libexec/colord from 'write' accesses on the unix_stream_socket unix_stream_socket.
Summary: SELinux is preventing /usr/libexec/colord from 'write' accesses on the unix_s...
Keywords:
Status: CLOSED DUPLICATE of bug 740358
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:6f9646fdffb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 18:43 UTC by Stephen Gallagher
Modified: 2011-09-21 19:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 19:41:39 UTC


Attachments (Terms of Use)

Description Stephen Gallagher 2011-09-21 18:43:10 UTC
SELinux is preventing /usr/libexec/colord from 'write' accesses on the unix_stream_socket unix_stream_socket.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that colord should be allowed write access on the unix_stream_socket unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep colord /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Context                system_u:system_r:init_t:s0
Target Objects                unix_stream_socket [ unix_stream_socket ]
Source                        colord
Source Path                   /usr/libexec/colord
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           colord-0.1.7-1.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.40.4-5.fc15.x86_64 #1 SMP Tue Aug 30 14:38:32
                              UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 21 Sep 2011 09:32:55 AM EDT
Last Seen                     Wed 21 Sep 2011 09:32:55 AM EDT
Local ID                      73313db2-d990-45e3-aea6-1cf96cca722b

Raw Audit Messages
type=AVC msg=audit(1316611975.389:31): avc:  denied  { write } for  pid=1390 comm="colord" path="socket:[15869]" dev=sockfs ino=15869 scontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=unix_stream_socket


type=SYSCALL msg=audit(1316611975.389:31): arch=x86_64 syscall=write success=yes exit=ECONNREFUSED a0=2 a1=1215100 a2=6f a3=1 items=0 ppid=1 pid=1390 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=colord exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0-s0:c0.c1023 key=(null)

Hash: colord,colord_t,init_t,unix_stream_socket,write

audit2allow

#============= colord_t ==============
allow colord_t init_t:unix_stream_socket write;

audit2allow -R

#============= colord_t ==============
allow colord_t init_t:unix_stream_socket write;

Comment 1 Daniel Walsh 2011-09-21 19:41:39 UTC

*** This bug has been marked as a duplicate of bug 740358 ***


Note You need to log in before you can comment on or make changes to this bug.