Bug 740365 - Sort + endless scroll busted on the Systems list page
Summary: Sort + endless scroll busted on the Systems list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-21 18:50 UTC by Partha Aji
Modified: 2013-08-16 18:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 18:48:22 UTC


Attachments (Terms of Use)
screenshot (81.61 KB, image/png)
2012-03-08 19:13 UTC, Jeff Weiss
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0665 normal SHIPPED_LIVE new packages: katello 2012-05-15 22:27:22 UTC

Description Partha Aji 2011-09-21 18:50:46 UTC
Description of problem:
1) When sorting a list of items in the Systems list page, the controller first gets a list of items based on a page size and then sorts them. So for example if the page size is 25 and I have 30 servers with the first one starting at A and the last one starting at Z, when I do a descending sort on name, what I 'd get is the First 25 randomly returned by the server based on the page size and then a sort of the result set. So the last server starting with the name Z won't show up. This is probably undesirable behaviour and diverges from typical expectations on pagination and sorting.

2) The endless scroll does not keep the sorting in mind. Its just based of an offset value. We should make the endless scroll preserve the sort order.


Steps to Reproduce:
1. Register 30+ system, you may want o use the bulk-loader  script.
2. Go to systems list page and sort by name on systems.
3. Scroll to the end of the page.
  
Actual results:
The items added to the list are not sorted and some of them may even be duplicated.

Expected results:

Sorted results appended to the scroll.
Additional info:

Comment 1 Justin Sherrill 2011-10-04 13:22:09 UTC
Should be fixed in master:
ff7029efadf81a0d50ae2afc17cb0b876a1343db

Comment 2 Mike McCune 2012-01-26 19:08:22 UTC
mass ON_QA move

Comment 5 Og Maciel 2012-02-24 20:16:05 UTC
Reassigned to developer as things will change in relation to how searches are handled. Also filed https://bugzilla.redhat.com/show_bug.cgi?id=797286 which resulted from verifying this issue.

Comment 6 Justin Sherrill 2012-02-27 16:31:02 UTC
Should be fixed in katello master:

2a7c27d081bbb14ff537985bea43877b83a13c42

Comment 8 Mike McCune 2012-03-07 23:44:11 UTC
mass move ON_QA after brewing

Comment 9 Jeff Weiss 2012-03-08 19:13:27 UTC
Created attachment 568727 [details]
screenshot

Comment 10 Jeff Weiss 2012-03-08 19:15:31 UTC
Fails QA, left pane does not stay sorted once extended scroll kicks in.

to repro:

1) add 30 systems
2) sort by name
3) scroll down

(see screenshot - google chrome 17)

I recommend this be deferred to post-v1.  not a blocker by any means.

Comment 11 Justin Sherrill 2012-03-09 14:56:15 UTC
Looks like extended scroll was actually misbehaving in general:
ba26c8036e31c74fd8444880f45b2503191cae77

Comment 13 Jeff Weiss 2012-03-09 20:09:16 UTC
Verified, Katello Version: 0.2.8-1.git.24.b178f46.el6

Comment 14 errata-xmlrpc 2012-05-15 18:48:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html

Comment 15 Mike McCune 2013-08-16 18:20:03 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.