Bug 740366 - RuntimeError: Returning partitions to state prior to edit failed
Summary: RuntimeError: Returning partitions to state prior to edit failed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9ee3d64536e9273243e50011031...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 18:51 UTC by Tim Flink
Modified: 2011-09-22 18:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 18:07:58 UTC


Attachments (Terms of Use)
File: anaconda-tb-WQVjTp (968.23 KB, text/plain)
2011-09-21 18:51 UTC, Tim Flink
no flags Details

Description Tim Flink 2011-09-21 18:51:44 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc6.git0.0.fc16.x86_64
product:        Fedora
reason:         RuntimeError: Returning partitions to state prior to edit failed
time:           Wed Sep 21 12:51:18 2011
version:        16-Beta

anaconda-tb-WQVjTp: Binary file, 991469 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.18 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/iw/partition_gui.py", line 1666, in editPartition
:    raise RuntimeError, ("Returning partitions to state "
:  File "/tmp/updates/pyanaconda/iw/partition_gui.py", line 1161, in treeActivateCB
:    self.editPartition(device, isNew = True)
:RuntimeError: Returning partitions to state prior to edit failed

Comment 1 Tim Flink 2011-09-21 18:51:48 UTC
Created attachment 524258 [details]
File: anaconda-tb-WQVjTp

Comment 2 Tim Flink 2011-09-21 18:59:00 UTC
I hit this while trying to test the update listed in bug 738964 comment 48.

Setup:
F16 Beta RC1 x86_64 DVD
 - using updates=http://dlehman.fedorapeople.org/updates-738964.2.img
VM with 2 virtio disks
 - 8BG with previous fedora install
 - 10GB empty

When I tried to use the full disk autopart option (selecting the 10G empty disk), I got an error saying that there wasn't enough space available on the disk to continue.

Then I went back and attempted to do custom partitioning. Anaconda crashed when I tried to create a 500M /boot partition on the empty disk.

Comment 3 David Lehman 2011-09-22 18:07:58 UTC
This was due to a bug in the updates image.


Note You need to log in before you can comment on or make changes to this bug.