Bug 740369 - Cursor disappears when window is redrawn
Summary: Cursor disappears when window is redrawn
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-vesa
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 842499
TreeView+ depends on / blocked
 
Reported: 2011-09-21 18:58 UTC by Jiri Koten
Modified: 2017-12-06 11:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 11:36:30 UTC


Attachments (Terms of Use)

Description Jiri Koten 2011-09-21 18:58:23 UTC
Description of problem:
When using Vesa driver there is problem with cursor rendering when the window is redrawn. Best examined using glxgears window or using firefox while the page is loading. The cursor just disappears until you move the mouse again, constantly flickers with glxgears, making hard to resize or move the window. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-vesa-2.3.0-2.el6
xorg-x11-server-Xorg-1.10.4-3.el6
kernel-2.6.32-199.el6

How reproducible:
100%

Steps to Reproduce:
1. run glxgears
2. move cursor to the window
  
Actual results:
cursor disappears/flickers

Expected results:
cursor is always visible.

Comment 2 Adam Jackson 2011-09-26 19:29:52 UTC
vesa doesn't have hardware cursor support, so this is sort of expected, we have to take the cursor down when things are rendered underneath it.  And this is going to be worse in a virtual machine than on real hardware since qemu updates the display on a timer, so the odds that you'll catch the server between cursor updates is higher.

I assume the cirrus test was in virt; was the vesa test in virt too?

Comment 3 Tomas Pelka 2011-09-26 20:50:33 UTC
For the cirrus yes on virt, for the vesa no as far as I can tell.

Comment 4 Jiri Koten 2011-09-27 07:51:34 UTC
The vesa test was on Intel GM45.

HW: T500 (2241B48)
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
[8086:2a42] (rev 07)

Comment 5 RHEL Product and Program Management 2011-10-07 16:18:48 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 8 Suzanne Yeghiayan 2012-02-14 23:16:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 9 Jan Kurik 2017-12-06 11:36:30 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.