Bug 740397 - Systems can be held by deleted recipes
Summary: Systems can be held by deleted recipes
Keywords:
Status: CLOSED DUPLICATE of bug 715226
Alias: None
Product: Beaker
Classification: Community
Component: inventory
Version: 0.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: Dan Callaghan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 21:30 UTC by Matt Brodeur
Modified: 2014-08-12 04:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 15:27:19 UTC


Attachments (Terms of Use)

Description Matt Brodeur 2011-09-21 21:30:06 UTC
Description of problem:
[16:25] <mbrodeur> bpeck: I think someone's used this feature to create an un-returnable system.
[16:25] <mbrodeur> https://beaker.engineering.redhat.com/view/dell-per210-01.lab.bos.redhat.com
[16:26] <mbrodeur> The return error refers to a deleted recipe. Canceling what would have been the right job number gives a successful result but the machine it still reserved.
[16:27] <bpeck> mbrodeur: I'm not sure what the chain of events are that gets us in this state
[16:27] <bpeck> mbrodeur: they shouldn't be able to delete a job that is still active
[16:28] <bpeck> the way I get around it for now is:
[16:28] <bpeck> 1) use bkr job-results R:RECIPID to find out the recipesetID
[16:28] <bpeck> 2) bkr job-cancel RS:recipesetID
[16:28] <bpeck> I did that just now to that recipe
[16:29] <bpeck> mbrodeur: you want to capture this irc session and open a bz


The root of the issue is that systems can remain assigned to a user after a job is complete.  I think there's a separate bug for that.  In this particular case, a completed job can be deleted while there's still a system that thinks it's being used.  The job being deleted makes it more difficult, but not impossible, to free the system.

Comment 1 Dan Callaghan 2011-09-21 22:10:52 UTC
I think this is the same as bug 715226.

Comment 2 Matt Brodeur 2011-09-22 15:27:19 UTC

*** This bug has been marked as a duplicate of bug 715226 ***


Note You need to log in before you can comment on or make changes to this bug.