Bug 740447 - duplicate Name for Bengali keyboard layouts in ibus-preference
Summary: duplicate Name for Bengali keyboard layouts in ibus-preference
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xkeyboard-config
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 05:25 UTC by A S Alam
Modified: 2013-07-03 01:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-31 06:38:12 UTC


Attachments (Terms of Use)
Screenshot for Bengali (65.74 KB, image/png)
2011-09-22 05:25 UTC, A S Alam
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 41204 None None None Never

Description A S Alam 2011-09-22 05:25:03 UTC
Created attachment 524319 [details]
Screenshot for Bengali

Description of problem:
after enabling keyboard layout from ibus for Bengali Language, it is showing both layout with same name. Benagli and Benagli

Version-Release number of selected component (if applicable):
xkeyboard-config-2.3-2.fc16.noarch
ibus-1.3.99.20110817-5.fc16.x86_64
ibus-m17n-1.3.3-4.fc16.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. add Bengali Keymap from Ibus Preference
2. there are two Bengali maps with same name
3.
  
Actual results:
 there are two Bengali maps with same name

Expected results:
there is same difference between those two, so that user can make choice


Additional info:

Comment 1 fujiwara 2011-09-26 03:26:09 UTC
IBus loads /usr/share/X11/xkb/rules/evdev.xml and there are duplicated 'Bengali' in evdev.xml.

    <layout>
      <configItem>
        <name>bd</name>
        <shortDescription>bn</shortDescription>
        <description>Bengali</description>
        <languageList>
          <iso639Id>ben</iso639Id>
        </languageList>
      </configItem>
...
...
    <layout>
      <configItem>
        <name>in</name>
        <shortDescription>in</shortDescription>
        <description>Indian</description>
      </configItem>
      <variantList>
        <variant>
          <configItem>
            <name>ben</name>
            <shortDescription>bn</shortDescription>
            <description>Bengali</description>
            <languageList>
              <iso639Id>ben</iso639Id>
            </languageList>
          </configItem>
        </variant>
        <variant>


I'd like to suggest to change the description in layout 'in' and variant 'ben' to distinguish layout 'bd'.

Transferring to xkeyboard-config.

Comment 2 Peter Hutterer 2011-09-26 04:06:06 UTC
upstreamed here: https://bugs.freedesktop.org/show_bug.cgi?id=41204

Comment 3 Peter Hutterer 2011-09-27 00:26:13 UTC
From the upstream maintainer Sergey V. Udaltsov:
"Actually, there was no promise that descriptions are going to be unique. But
you could come up with the good different names - we could discuss that."

Comment 4 fujiwara 2011-09-27 10:04:40 UTC
I don't mind any names. How about the following change?

--- /usr/share/X11/xkb/rules/evdev.xml.orig
+++ /usr/share/X11/xkb/rules/evdev.xml
@@ -1714,7 +1714,7 @@
           <configItem>
             <name>ben</name>
             <shortDescription>bn</shortDescription>
-            <description>Bengali</description>
+            <description>Indian (Bengali)</description>
             <languageList>
               <iso639Id>ben</iso639Id>
             </languageList>
@@ -1724,7 +1724,7 @@
           <configItem>
             <name>ben_probhat</name>
             <shortDescription>bn</shortDescription>
-            <description>Bengali (Probhat)</description>
+            <description>Indian (Bengali (Probhat))</description>
             <languageList>
               <iso639Id>ben</iso639Id>
             </languageList>

Comment 5 Peter Hutterer 2011-09-28 00:22:45 UTC
hmm, not a big fan of the double-nested parens. I just noticed that for German (Austria) and English (US) the style is to use a comma for variants so I think the right way here would be Indian (Bengali) and Indian (Bengali, probhat).
I'll suggest that to svu upstream.

Comment 6 A S Alam 2011-09-28 01:39:03 UTC
(In reply to comment #5)
> hmm, not a big fan of the double-nested parens. I just noticed that for German
> (Austria) and English (US) the style is to use a comma for variants so I think
> the right way here would be Indian (Bengali) and Indian (Bengali, probhat).
> I'll suggest that to svu upstream.

Better it can "Bengali" and "Bengali Probhat" (skip Indian as script also used in Bangladesh)

Comment 7 A S Alam 2011-09-28 01:40:58 UTC
Runa, Any suggestion regarding this?

Comment 8 fujiwara 2011-09-28 02:32:26 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > hmm, not a big fan of the double-nested parens. I just noticed that for German
> > (Austria) and English (US) the style is to use a comma for variants so I think
> > the right way here would be Indian (Bengali) and Indian (Bengali, probhat).
> > I'll suggest that to svu upstream.
> 
> Better it can "Bengali" and "Bengali Probhat" (skip Indian as script also used
> in Bangladesh)

The problem is the duplicated names. The "Bengali" is already used in layout 'bd' and the suggestion is for layout 'in', variant 'bn'.
Probably it would be good to check the upstream bug.
Personally I agree with the upstream suggestion.

I can find 'Indian' for layout 'in' only in /usr/share/X11/xkb/rules/evdev.xml .

Comment 9 Runa Bhattacharjee 2011-09-28 03:01:58 UTC
If we have to strictly distinguish based upon the 'in' and 'bd' groups, I'd have to second comment #5 here.

Comment 10 Peter Hutterer 2011-09-28 05:15:06 UTC
from a quick check, the in(ben) and bd layouts are different so a different name is certainly important here. You've probably seen the upstream comment, instead of what i suggested in comment #5 it should be "Bengali (India)" instead. Does that sound alright?

Comment 11 Runa Bhattacharjee 2011-09-28 06:34:47 UTC
Given the regulations, the upstream suggestion sounds good to go. I really don't see anything else that we can use for the xkb maps.

Comment 12 fujiwara 2011-09-28 09:00:52 UTC
Yes, I also agree with the upstream suggestion.

Comment 13 Peter Hutterer 2013-01-31 06:38:12 UTC
fwiw, this has been fixed since xkeyboard-config 2.4.1 which was somewhen in the F14 timeframe. Closing.


Note You need to log in before you can comment on or make changes to this bug.