Bug 74045 - [compat-libgcj-devel] Does not work when installed with an umask of 077 and messes filesystem
Summary: [compat-libgcj-devel] Does not work when installed with an umask of 077 and m...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: compat-gcc   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 20:35 UTC by Enrico Scholz
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 13:09:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 20:35:05 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include/gcj
| file /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include is not owned by any package
| compat-libgcj-devel-7.3-2.96.110

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

compat-libgcj-devel-7.3-2.96.110


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that compat-libgcj-devel is uninstalled completely
   (rm -rf /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include)
3. rpm -U compat-libgcj-devel-7.3-2.96.110.i386.rpm
4. ls -l /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e compat-libgcj-devel-7.3-2.96.110


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 22:18 /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include
* files can not be found/read at 5 and
* /usr/lib/gcc-lib/i386-redhat-linux7/2.96/include still exists after 6.

Comment 1 Jakub Jelinek 2004-10-07 13:09:55 UTC
I believe current gcc owns all necessary directories.


Note You need to log in before you can comment on or make changes to this bug.