Bug 740508 - [virsh command]The option --paused and --running belong to command save-image-define don't work.
Summary: [virsh command]The option --paused and --running belong to command save-image...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Eric Blake
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 733762
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 09:48 UTC by kjia
Modified: 2011-12-06 11:33 UTC (History)
10 users (show)

Fixed In Version: libvirt-0.9.4-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:33:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description kjia 2011-09-22 09:48:48 UTC
Description of problem:
The option --paused and --running belong to command save-image-define don't work.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-11.el6.x86_64

How reproducible:
always

Steps to Reproduce:

For --paused option:
Need an activity domain.
1. virsh save $domain_name ./$domain_name.save
2. virsh save-image-dumpxml $domain_name.save > tmp.xml
3. virsh save-image-define rhel62.save rhel62.xml --paused
4. virsh  restore rhel62.save

For --running option:
Need a paused domain.
1. virsh save $domain_name ./$domain_name.save
2. virsh save-image-dumpxml $domain_name.save > tmp.xml
3. virsh save-image-define rhel62.save rhel62.xml --running
4. virsh  restore rhel62.save

Actual results:

For --paused option:
After step 4 above, the status of $domain_name is running.

 Id Name                 State
----------------------------------
  7 rhel62               running

For --running option:
After step 4 above, the status of $domain_name is running.

 Id Name                 State
----------------------------------
  7 rhel62               paused

Expected results:

For --paused option:
After step 4 above, the status of $domain_name should be paused.

 Id Name                 State
----------------------------------
  7 rhel62               paused

For --running option:
After step 4 above, the status of $domain_name is running.

 Id Name                 State
----------------------------------
  7 rhel62               running

Additional info:

Comment 2 kjia 2011-09-22 10:02:38 UTC
This bug exist in libvirt-0.9.4-12.el6.x86_64 as well.

Comment 3 kjia 2011-09-22 10:20:10 UTC
The version of qemu-kvm is qemu-kvm-0.12.1.2-2.185.el6.x86_64
and the version of kernel is kernel-2.6.32-201.el6.x86_64

Comment 4 Osier Yang 2011-09-22 12:10:54 UTC
patch posted to upstream.

https://www.redhat.com/archives/libvir-list/2011-September/msg00896.html

Comment 8 yanbing du 2011-09-26 07:18:24 UTC
With libvirt-0.9.4-13.el6.x86_64, both --running and --pause option work well.
Move this bug to VERIFIED.

Comment 9 errata-xmlrpc 2011-12-06 11:33:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.