Bug 740558 - TestPlan.update() ignores the is_active flag
Summary: TestPlan.update() ignores the is_active flag
Keywords:
Status: CLOSED DUPLICATE of bug 841189
Alias: None
Product: TCMS
Classification: Other
Component: Application
Version: 3.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.8.0
Assignee: jianchen
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 13:07 UTC by Petr Šplíchal
Modified: 2016-06-01 01:47 UTC (History)
11 users (show)

Fixed In Version: 3.8.0-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-31 02:37:01 UTC


Attachments (Terms of Use)

Description Petr Šplíchal 2011-09-22 13:07:40 UTC
Description of problem:

Updating the 'is_active' using TestPlan.update() does not have any
effect. The value stays the same.

Version-Release number of selected component (if applicable):
Nitrate 3.5.0

Steps to Reproduce:
1. Update the is_active flag
2. Fetch again the same test plan
  
Actual results:
Value not updated.

Comment 1 Petr Šplíchal 2011-09-22 13:10:03 UTC
This is now covered by Nitrate (high-level API) test suite:
https://wiki.test.redhat.com/BaseOs/Projects/PythonNitrate

Test read & write access to the 'active' flag ...
[INFO] Fetching test plan TP#289
[INFO] Contacting server https://tcms-stage.englab.bne.redhat.com/xmlrpc/
[DEBUG] Initializing test plan TP#289
[DEBUG] {'attachment': [],
 'author': 'psplicha',
 'author_id': 2117,
 'case': [12516, 35267, 46490, 51362, 35269],
 'component': [],
 'create_date': '2008-10-22 09:08:38',
 'default_product_version': '6.1',
 'env_group': [],
 'extra_link': '',
 'is_active': True,   <---------------------------------------
 'name': 'Tessst plan',
 'owner': 'psplicha',
 'owner_id': 2117,
 'parent': 'Tessst',
 'parent_id': 1329,
 'plan_id': 289,
 'product': 'Red Hat Enterprise Linux 6',
 'product_id': 60,
 'tag': [973, 1379, 1380, 1381],
 'type': 'Function',
 'type_id': 3}
[INFO] Updating test plan TP#289
[DEBUG] {'default_product_version': 995,
 'is_active': False,   <---------------------------------------
 'name': 'Tessst plan',
 'parent': 1329,
 'product': 60,
 'type': 3}
[INFO] Fetching test plan TP#289
[DEBUG] Initializing test plan TP#289
[DEBUG] {'attachment': [],
 'author': 'psplicha',
 'author_id': 2117,
 'case': [12516, 35267, 46490, 51362, 35269],
 'component': [],
 'create_date': '2008-10-22 09:08:38',
 'default_product_version': '6.1',
 'env_group': [],
 'extra_link': '',
 'is_active': True,   <---------------------------------------
 'name': 'Tessst plan',
 'owner': 'psplicha',
 'owner_id': 2117,
 'parent': 'Tessst',
 'parent_id': 1329,
 'plan_id': 289,
 'product': 'Red Hat Enterprise Linux 6',
 'product_id': 60,
 'tag': [973, 1379, 1380, 1381],
 'type': 'Function',
 'type_id': 3}
FAIL

Comment 2 Petr Šplíchal 2012-01-23 09:06:18 UTC
It's been a couple of months already. Any ETA for fixing this bug?

Comment 3 yawei Li 2012-05-18 03:37:05 UTC
in 3.8.0, will implement it.

Comment 4 jianchen 2012-06-26 06:45:36 UTC
(In reply to comment #2)
> It's been a couple of months already. Any ETA for fixing this bug?

TestPlan.update() is_active accept 0 or 1, 0 --> False and 1 --> True.
TestPlan.update(3551, {'is_active': 1}) is worked in stage server.
I will update xmlrpc's document about this argument.
Thanks.

Comment 5 yawei Li 2012-07-26 07:45:26 UTC
Reopened to trace the document update.

Comment 6 jianchen 2012-07-26 08:33:35 UTC
TestPlan.update() is_active accept True/False now. 
pls verify in stage server after tcms 3.8.0-2 release.

Comment 7 jianchen 2012-07-31 02:37:01 UTC

*** This bug has been marked as a duplicate of bug 841189 ***


Note You need to log in before you can comment on or make changes to this bug.