Bug 740579 - acroread consumes 100% CPU on exit
Summary: acroread consumes 100% CPU on exit
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: acroread
Version: 6.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 782183
TreeView+ depends on / blocked
 
Reported: 2011-09-22 14:38 UTC by John Bramley
Modified: 2018-11-26 18:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-23 14:02:04 UTC


Attachments (Terms of Use)

Description John Bramley 2011-09-22 14:38:29 UTC
Description of problem:
When acroread is exited the window closes but the process doesn't exit and consumes 100% CPU and requires KILL signal to stop it

Version-Release number of selected component (if applicable):
acroread-9.4.2-5.el6.i686

How reproducible:
Alway

Steps to Reproduce:
1. run 'acroread'
2. close Acrobat reader (e.g. File/Exit)
3. top shows acroread CPU% at around 100
4. 'pkill acroread' fails to kill process
5. 'pkill -9 acroread' kills it
  
Actual results:
Acrobat Reader process continues, with CPU% going to 100% after the window is closed.  Trying to start further instances by running 'acroread' fail - commands just hang, until initial acroread process is killed with KILL signal (pkill -9 acroread)

Expected results:
acroread process should exit when the window is closed.

Additional info:
Worked ok before a recent system update.
strace doesn't show anything when connected to the process consuming 100% CPU

Comment 2 RHEL Product and Program Management 2011-09-22 15:08:24 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Andrei Maslennikov 2012-03-06 09:41:44 UTC
I can confirm that this behaviour still persists with RHEL 6.2 and acrobat reader 9.4.7-1. It is very annoying...

Comment 6 RHEL Product and Program Management 2012-07-10 06:31:01 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 7 RHEL Product and Program Management 2012-07-10 23:03:43 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 8 RHEL Product and Program Management 2012-09-07 05:19:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 10 Vincent S. Cojot 2013-07-22 21:17:11 UTC
I can confirm this behaviour on RHEL6.4 even with latest updates (as of July 22nd 2013). The acroread process appears to be stuck into an 'inotify' loop when exited..

Comment 11 Vincent S. Cojot 2013-07-22 21:22:17 UTC
# rpm -q acroread
acroread-9.5.5-1.el6_4.i686
# uname -a
Linux rh6x64 2.6.32-358.14.1.el6.x86_64 #1 SMP Mon Jun 17 15:54:20 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux
# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.4 (Santiago)

[raistlin@rh6x64 ~]$ rm -rf .adobe 
[raistlin@rh6x64 ~]$ acroread &
[1] 7214
[raistlin@rh6x64 ~]$ 
[raistlin@rh6x64 ~]$ sudo strace -f -p 7214
[sudo] password for raistlin: 
Process 7214 attached with 2 threads - interrupt to quit
[ Process PID=7445 runs in 32 bit mode. ]
[pid  7445] restart_syscall(<... resuming interrupted call ...>) = 0
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000) = 0 (Timeout)
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000) = 0 (Timeout)
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000) = 0 (Timeout)
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000) = 0 (Timeout)
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000) = 0 (Timeout)
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000) = 0 (Timeout)
[pid  7445] poll([{fd=9, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}, {fd=10, events=POLLIN|POLLPRI|POLLERR|POLLHUP|POLLNVAL}], 2, 1000^C <unfinished ...>
Process 7214 detached
Process 7445 detached

[raistlin@rh6x64 ~]$ ls -la /proc/7445/fd/9
lr-x------ 1 raistlin users 64 Jul 22 17:21 /proc/7445/fd/9 -> inotify
[raistlin@rh6x64 ~]$ ls -la /proc/7445/fd/10
lrwx------ 1 raistlin users 64 Jul 22 17:21 /proc/7445/fd/10 -> socket:[23519]

Comment 12 Vincent S. Cojot 2013-07-22 21:23:51 UTC
[root@rh6x64 ~]# netstat -an|grep 23519
unix  3      [ ]         STREAM     CONNECTED     23519

Comment 13 Vincent S. Cojot 2013-07-22 21:24:21 UTC
[root@rh6x64 ~]# lsof |grep 23519
acroread   7214  raistlin   10u     unix 0xffff88010a3b8980       0t0      23519 socket

Comment 14 Vincent S. Cojot 2013-07-23 13:53:38 UTC
Seems the issue isn't exactly new:
https://bugzilla.novell.com/show_bug.cgi?id=618207

Comment 15 Marek Kašík 2013-07-23 14:02:04 UTC
Hi,

I'm closing this bug because we can not fix it. We do not have access to Adobe Reader's internals.

Regards

Marek

Comment 16 Vincent S. Cojot 2013-07-23 14:11:57 UTC
Could this be reported to Adobe, at least?

Comment 17 Marek Kašík 2013-07-23 14:51:48 UTC
(In reply to Vincent S. Cojot from comment #16)
> Could this be reported to Adobe, at least?

Unfortunately not. Adobe's Bugbase doesn't contain Adobe Reader.


Note You need to log in before you can comment on or make changes to this bug.