This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 740582 - autogroups have bad group and individual links
autogroups have bad group and individual links
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
3.0.0 Beta1
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: Lukas Krejci
Mike Foley
:
Depends On:
Blocks: jon30-bugs rhq42
  Show dependency treegraph
 
Reported: 2011-09-22 10:57 EDT by Nabeel Saad
Modified: 2015-11-01 19:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nabeel Saad 2011-09-22 10:57:10 EDT
Description of problem:
Installing a basic JON 3.0.0.Beta1 JON server locally, having the embedded agent running, I import my local machine as a resource.  Then, when I click onto the CPU folder, it expands and shows me that I have two cores.  This all works fine; however, in the Monitoring -> Graphs tabs, each graph specifies it's name and has hyperlinked text pointing back to the "[CPU]" folder group.  It's the same if you click into any of the CPU 0 or CPU 1 inside the folder.

Clicking on the [CPU] hyperlink will attempt to go to a ResourceGroup with ID 10001.  This then attempts to go to the Inventory -> Groups subsection but throws a message "Group with id [10001] does not exist or is not accessible".

Version-Release number of selected component (if applicable):
JON 3.0.0.BETA1

How reproducible:
Everytime

Steps to Reproduce:
1.Install basic JON 3.0.0.BETA1 version
2.Import local machine (preferably with two CPUs, but not necessary - I believe) as a resource into the inventory
3.Click into the platform, and then click onto the CPU folder 
3'You could also click into one of the CPUs inside the folder
4.Click Monitoring -> Graphs
5.Near the standard graphs, for example System Load [CPU], click the CPU hyperlink
  
Actual results:
Inventory page loads with error: "Group with id [10001] does not exist or is not accessible".

Expected results:
To be taken to the CPU folder that you were on

Additional info:
Comment 1 Charles Crouch 2011-09-26 09:59:02 EDT
Although not directly related we should fix this at the same time as 
https://bugzilla.redhat.com/show_bug.cgi?id=736848
Comment 2 Heiko W. Rupp 2011-09-28 11:33:15 EDT
Make sure that if a Group with id 10001 exists, this is actually showing the intended data, metrics and resources.
Comment 3 Nabeel Saad 2011-09-29 03:53:34 EDT
I think the issue is more so that the "fake" group - I don't know what you guys name them internally - should have a unique ID that would not get mixed up with regular "groups".
Comment 4 Lukas Krejci 2011-10-03 10:49:26 EDT
The correct URLs now should be generated when viewing a compatible group, an auto group and auto cluster (i.e. children in the tree of a recursive compatible group).

commit b53f710b1149a6552b6d2dabb47544f3bf94a167
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Mon Oct 3 14:32:57 2011 +0200

    BZ 740582 - generate correct group URLs in the JSF-based metric graphs page in various contexts.
Comment 5 Sunil Kondkar 2011-10-04 07:01:13 EDT
Verified on build#459 (Version: 4.1.0-SNAPSHOT Build Number: 8368e38)

Clicked on the platform, and then to the CPU folder and one of the CPUs inside the folder. Navigated to Monitoring -> Graphs tab. Clicked on the CPU hyperlink (in System Load [CPU 0]). This navigates correctly to the 'Summary->Activity' page of the CPU 0.
Aslo verified that the navigation works correctly clicking hyperlinks in Monitoring -> Graphs tab in compatible groups, autogroups, and cluster groups.
Comment 6 Nabeel Saad 2011-10-04 11:03:47 EDT
Hello Sunil, Lukas,

Is there anyway I would be able to test this with any JON product version (I currently have 3.0.0-Beta1) or do I have to wait till JON 3 is released? 

I just wanted to do a quick test cause from your description Sunil, it slightly differs to what I did in my bug description.  When I clicked on the CPU folder, then clicked into Monitoring -> Graphs tab, above the graphs, I saw text that said "System Load [CPU]" not "System Load [CPU 0]".  The CPU 0 text worked fine before, it's the clicking on the CPU text that was throwing an error where it should have gone back to the CPU folder.

Thanks,
Nabeel
Comment 7 Lukas Krejci 2011-10-05 05:35:55 EDT
Nabeel,

what you describe - i.e. clicking on the CPU folder, going to Monitoring->Graphs and clicking on "CPU" in "System Load [CPU]" - is clicking on an "autogroup" link, which Sunil also mentions as having checked.

As for the next product version - I'm not sure when but I'd be surprised if we didn't release another Beta or CR before the JON 3 final.
Comment 8 Mike Foley 2012-02-07 14:30:58 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE
Comment 9 Mike Foley 2012-02-07 14:31:00 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.