Bug 740584 - Chrome: Hitting tab on user delete confirmation modal results in all focus lost.
Summary: Chrome: Hitting tab on user delete confirmation modal results in all focus lost.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Jason E. Rist
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-22 14:59 UTC by Corey Welton
Modified: 2019-09-26 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:57:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Welton 2011-09-22 14:59:48 UTC
Description of problem:

Probably stemming from the fix for bug #705868, if user hits tab in the confirm modal in chrome, all focus is lost -- sometimes disallowing any mouseclick at all.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a user
2.  Click the Remove User link
3.  On the resulting confirmation screen, note mouse focus.
4.  Hit the tab button (possibly multiple times)
  
Actual results:
Focus is lost.  In some cases, any ability to click either yes/no is lost, but that doesn't seem to be 100% of the time

Expected results:
Tab should change focus to other button on screen; repeated tabs should toggle the focus.

Additional info:

Comment 1 Garik Khachikyan 2011-10-21 12:31:24 UTC
same stuff happens for me on env. removal.

Comment 2 Jason E. Rist 2011-10-25 13:21:12 UTC
I've put in a fix to at least make the tabindex go from no to yes, but this is actually supposed to be fixed in 1.9 jquery ui.  See the following bug report:

http://bugs.jqueryui.com/ticket/3123

Also I added the ability to close (basically hit no) by hitting the escape key.

Comment 3 Jason E. Rist 2012-01-11 21:27:25 UTC
commit 681b0dbb8d151002ed6a7ba30063b992ec015900
Author: Jason E. Rist <jrist@redhat.com>
Date:   Wed Jan 11 14:02:39 2012 -0700

    740584 - Fix for buttons within jQuery UI Dialog.

Comment 4 Corey Welton 2012-01-17 20:53:28 UTC
Verified.

Comment 7 Mike McCune 2013-08-16 18:11:15 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.