Bug 740613 - Kernel crashed when running heavy job
Summary: Kernel crashed when running heavy job
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 16:41 UTC by Manoj Gupta
Modified: 2011-10-19 20:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-19 20:31:13 UTC


Attachments (Terms of Use)
log file with information of update and crash (312.81 KB, text/plain)
2011-09-22 16:41 UTC, Manoj Gupta
no flags Details

Description Manoj Gupta 2011-09-22 16:41:07 UTC
Created attachment 524451 [details]
log file with information of update and crash

Description of problem:
I ran a job which was doing some heavy computation using huge amount of data (> 200GB). After sometime the system hung up, because of the kernel crashed. No network working, no display on the monitor. However, computer power is on. This started on Sep 20 after update on Sep 19. 

Version-Release number of selected component (if applicable):
Fedora 15

How reproducible:
Run job which uses more 200GB of data, and runs for more than an hour

Steps to Reproduce:
1.
2.
3.
  
Actual results:
System hung up. Stop network working, no display in the monitor. However, computer power is on.

Expected results:
Job should finished normally, without crashing the kernel.

Additional info:
I guess it started after update. The log file is attached.
System: 8 core 64bit AMD, 32 GB RAM, 40 GB swap, running fedora 15 64bit.

Comment 1 Manoj Gupta 2011-09-22 16:44:01 UTC
There was no way to shutdown the system except manual shutdown. 

System hang up happened today again when running similar kind of job.

Comment 2 Manoj Gupta 2011-09-22 17:11:41 UTC
Before I was using Fedora 8 32bit, and I never had problem like this.

Comment 3 Dave Jones 2011-09-22 18:27:15 UTC
These sorts of problems are best diagnosed by talking directly with the upstream memory management developers.  You can find them at linux-mm@kvack.org


Note You need to log in before you can comment on or make changes to this bug.