Bug 74065 - loadkeys does not load strings
loadkeys does not load strings
Status: CLOSED DUPLICATE of bug 74064
Product: Red Hat Public Beta
Classification: Retired
Component: kbd (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-14 02:12 EDT by Vladimir Kolpakov
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-14 02:12:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kolpakov 2002-09-14 02:12:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010914

Description of problem:
loadkeys -s still been able to erase keyboard strings in the kernel,
but there is no way to load new strings descriptors anymore.

How reproducible: 
Always

Steps to Reproduce:
1.dumpkeys > /tmp/default_keys
2.loadkeys -s
3.loadkeys ru
4.dumpkeys > /tmp/ru_keys
5.See difference in near bottom part, just before compose-s list.
6.copy loadkeys binary from mandrake "consoletools" package.
7.run mandrake's loadkeys with the same keymap and see difference.


Actual Results:  linux console is non-functional anymore for national people,
and products with extensive using of keyboard midifiers.

Expected Results:  strings must be overwritten

Additional info:

Result of dumpkeys with custom keymap table,
loaded by mandrake's loadkeys:
--------------------------------
[...]
        shift   control alt     keycode 126 = AltGr_Lock      
keycode 127 =
string F1 = "\033[[A"
string F2 = "\033[[B"
[...]
string F22 = "\033[36~"
string F101 = "\033[7^"
string F102 = "\033[8^"
string F103 = "\033[5B"
string F104 = "\033[5A"
string F105 = "\033[5D"
string F106 = "\033[5C"
string F107 = "\033[2;5~"
string F108 = "\033[3^"
string F109 = "\033[3$"
string F110 = "\033{7~"
compose '!' '!' to '?'
compose '"' 'A' to '?'
[...]
---------------------------------------
--w
Comment 1 Vladimir Kolpakov 2002-09-14 02:17:24 EDT
Closing second instance same bug,
accidentally submitted by the Back button in we browser.


*** This bug has been marked as a duplicate of 74064 ***

Note You need to log in before you can comment on or make changes to this bug.