Bug 740664 - xen-platform-pci needs to be builtin or part of initramfs
Summary: xen-platform-pci needs to be builtin or part of initramfs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 747617 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 21:11 UTC by Jeremy Fitzhardinge
Modified: 2011-10-20 16:58 UTC (History)
6 users (show)

Fixed In Version: kernel-3.1.0-0.rc8.git0.0.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 21:17:08 UTC


Attachments (Terms of Use)

Description Jeremy Fitzhardinge 2011-09-22 21:11:17 UTC
Description of problem:
When running F16 as an HVM Xen domain, the xen-platform-pci driver needs to be present.  If it isn't, then the kernel will unplug the emulated disk and net devices, but never load the corresponding Xen netfront and blkfront drivers, resulting in a system which has no root filesystem.

Version-Release number of selected component (if applicable):
kernel-3.1.0-0.rc6.git0.3.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install kernel
2. Boot as HVM under Xen
3.
  
Actual results:
Boot fails, because it can't find a root filesystem (or any LVM disks)

Expected results:
Boot on PV drivers

Additional info:
Adding "xen-platform-pci" to the dracut config and rebuilding fixes this for me, but the driver should probably just be built in rather than modular.

Comment 1 Dave Jones 2011-09-22 22:34:10 UTC
ok, made this =y.  I assume there's no downside to having this always loaded on baremetal ?

Comment 2 Jeremy Fitzhardinge 2011-09-22 22:45:51 UTC
Nope.  It's just a PCI device driver, so if the device isn't present it does nothing.

Comment 3 Fedora Update System 2011-09-28 14:36:06 UTC
kernel-3.1.0-0.rc8.git0.0.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc8.git0.0.fc16

Comment 4 Fedora Update System 2011-09-28 18:51:30 UTC
Package kernel-3.1.0-0.rc8.git0.0.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.0-0.rc8.git0.0.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc8.git0.0.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-10-04 21:16:58 UTC
kernel-3.1.0-0.rc8.git0.0.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Paolo Bonzini 2011-10-20 16:58:05 UTC
*** Bug 747617 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.