Bug 74068 - Privoxy won't allow display of CUPS website correctly
Privoxy won't allow display of CUPS website correctly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: privoxy (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-14 10:51 EDT by Joshua Jensen
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 08:46:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-09-14 10:51:40 EDT
Description of Problem:

When mozilla uses provoxy, and you surf to http://localhost:631, the page never
fully loads.  Disabling privoxy allows things to work well.

Version-Release number of selected component (if applicable):

stock Psyche pre-respin
Comment 1 Joshua Jensen 2003-01-03 12:23:21 EST
This seems to be true for the public beta too
Comment 2 Karsten Hopp 2003-07-09 08:46:35 EDT
one of the privoxy maintainers had a look at this and wrote that 
"Cups' httpd ignores Privoxy's "Connection: close" header and tries 
Keep-Alive, which if true would point at a bug in cups." 
 
His current workaround is to add the following lines to the privoxy rules: 
 
{+downgrade-http-version} 
:631 
 
 

Note You need to log in before you can comment on or make changes to this bug.