Bug 740688 - iwhd daemon no longer checks for mongodb
Summary: iwhd daemon no longer checks for mongodb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: iwhd
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Jim Meyering
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 23:18 UTC by wes hayutin
Modified: 2013-03-13 20:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 19:55:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0589 normal SHIPPED_LIVE new packages: iwhd 2012-05-15 22:31:24 UTC

Description wes hayutin 2011-09-22 23:18:02 UTC
Description of problem:

At one point .. maybe a while ago.. the iwhd daemon checked if mongodb was running. If was not running it would error out w/.

waiting for mongod to listen on localhost:27017[FAILED]
Starting iwhd daemon"),"daemon doesn't attempt to start"

I'm not sure if this is still a feature.. however currently the daemon just fails w/o reference to mongodb or any notice in the /var/log/iwhd.log

It would help an end user if the condition was logged to /var/log/iwhd.log

Comment 1 wes hayutin 2011-09-22 23:19:02 UTC
version tested...

commit af161e18fbf58669ba1d6dca6de20fd211bd4b76
Author: Pete Zaitcev <zaitcev@redhat.com>
Date:   Wed Sep 14 16:22:47 2011 +0200

Comment 2 Chris Lalancette 2011-09-23 14:53:42 UTC
So actually the thing is that iwhd still does this check.  However, it is now hidden behind systemd.

The quick summary is that "service foo start" puts a message on dbus, then systemd (init) picks up the message off of dbus, finds /etc/init.d/iwhd, and then execs it.

The problem is most likely that it is checking for mongod, but not properly returning a non-zero error code when it doesn't find it.  There is a further problem in that it also doesn't report an error message anywhere.  Both of these probably need to be fixed in the iwhd initscript.

Comment 3 Jim Meyering 2011-09-26 14:44:35 UTC
AFAICS, this was fixed by the commit mentioned in comment #1, so this is no longer a problem with iwhd.

Comment 5 Aziza Karol 2011-10-12 10:55:54 UTC
iwhd daemon checks for mongodb.

[root@dell-pe1950-02 templates]# service mongod stop
Stopping mongod: [  OK  ]
[root@dell-pe1950-02 templates]# service iwhd stop
[  OK  ] iwhd daemon:  [  OK  ]


[root@dell-pe1950-02 templates]# service iwhd start
waiting for mongod to listen on localhost:27017[FAILED]


I see that that the iwhd checks for mongod, but nothing is logged in iwhd.log
[root@dell-pe1950-02 ~]# tail -f /var/log/iwhd.log



An error message/condition should be reported in iwhd.log.


[root@dell-pe1950-02 templates]# rpm -qa  | egrep  'conductor|iwhd'
aeolus-conductor-0.5.0-0.20111007200330gite77b251.el6.noarch
aeolus-conductor-doc-0.5.0-0.20111007200330gite77b251.el6.noarch
iwhd-0.98.15.z3-2.el6.x86_64
aeolus-conductor-daemons-0.5.0-0.20111007200330gite77b251.el6.noarch

Comment 6 Jim Meyering 2011-10-12 11:45:51 UTC
Thanks for the report, but you have misinterpreted the silence.
It is not an error for mongodb to become unavailable, now.
iwhd will reconnect when it returns, and there is no timeout.

From the NEWS:

* Noteworthy changes in release 0.99 (2011-10-10) [stable]

** Bug fixes

  iwhd now continues to work properly when mongo dies and is restarted.
  Before, it would dump core due to an unhandled SocketException.

Comment 7 Jim Meyering 2011-10-12 11:46:57 UTC
If the lack of a log message is causing trouble, please give details, but preferably in a new BZ.

Comment 8 Dave Johnson 2011-10-21 15:42:38 UTC
closing this one out, created a new bug 747984 to get better iwhd logging

Comment 10 errata-xmlrpc 2012-05-15 19:55:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0589.html


Note You need to log in before you can comment on or make changes to this bug.