Bug 740692 - [abrt] kernel: BUG: Bad page map in process audacious pte:a00007803056b961 pmd:8e8d4067: TAINTEDDie
Summary: [abrt] kernel: BUG: Bad page map in process audacious pte:a00007803056b961 p...
Keywords:
Status: CLOSED DUPLICATE of bug 740602
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:202142857
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 23:52 UTC by David Kovalsky
Modified: 2014-03-31 23:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 16:03:17 UTC


Attachments (Terms of Use)
File: backtrace (1.17 KB, text/plain)
2011-09-22 23:52 UTC, David Kovalsky
no flags Details

Description David Kovalsky 2011-09-22 23:52:31 UTC
abrt version: 1.1.18
architecture: x86_64
cmdline: not_applicable
comment: I know there's kernel taint, but I haven't seen this in the past. Nvidia binary drivers have always been very stable for my setup.
component: kernel
executable: kernel
kernel: 2.6.35.14-97.fc14.x86_64
package: kernel
reason: BUG: Bad page map in process audacious  pte:a00007803056b961 pmd:8e8d4067
release: Fedora release 14 (Laughlin)
tainted: 161
time: 1316735133
uid: 0

backtrace
-----
BUG: Bad page map in process audacious  pte:a00007803056b961 pmd:8e8d4067
addr:000000332923a000 vm_flags:08000070 anon_vma:(null) mapping:ffff880122ef01d8 index:3a
vma->vm_ops->fault: filemap_fault+0x0/0x30a
vma->vm_file->f_op->mmap: ext4_file_mmap+0x0/0x54
Pid: 9490, comm: audacious Tainted: P    B D     2.6.35.14-97.fc14.x86_64 #1
Call Trace:
 [<ffffffff810e9f87>] print_bad_pte+0x1aa/0x1c3
 [<ffffffff810eadfd>] vm_normal_page+0x68/0x87
 [<ffffffff810eb73a>] unmap_vmas+0x390/0x760
 [<ffffffff810f140e>] exit_mmap+0xa2/0x119
 [<ffffffff8104b781>] mmput+0x60/0xce
 [<ffffffff81051262>] exit_mm+0x11a/0x127
 [<ffffffff8146b24e>] ? _raw_spin_lock_irq+0x1f/0x21
 [<ffffffff810514be>] do_exit+0x24f/0x74f
 [<ffffffff8105ca8a>] ? recalc_sigpending_tsk+0x3a/0x41
 [<ffffffff81051c38>] do_group_exit+0x7a/0xa2
 [<ffffffff8105e751>] get_signal_to_deliver+0x372/0x398
 [<ffffffff81008fc9>] do_signal+0x72/0x690
 [<ffffffff8146b1fe>] ? _raw_spin_lock+0xe/0x10
 [<ffffffff812188dd>] ? _atomic_dec_and_lock+0x2d/0x4c
 [<ffffffff8112da3d>] ? mntput_no_expire+0x25/0xa4
 [<ffffffff81076d11>] ? sys_futex+0x134/0x143
 [<ffffffff81009628>] do_notify_resume+0x28/0x86
 [<ffffffff81009f80>] int_signal+0x12/0x17

How to reproduce
-----
1. Play some Joe Cocker mp3s in Audacious to one's son to calm down
2. Fall asleep for a couple of hours (both)
3. Close Audacious once up. Audacious froze there for a couple of seconds. Maybe this is related to recent upgrade to 2.6.35.14-97.fc14.x86_64

Comment 1 David Kovalsky 2011-09-22 23:52:35 UTC
Created attachment 524519 [details]
File: backtrace

Comment 2 Josh Boyer 2011-09-23 00:25:11 UTC
You'll need to recreate this without the nvidia module loaded.  Also, we might just dupe it to 740602 since this is most likely just a continuation of the issues seen there.

Comment 3 Dave Jones 2011-09-26 16:03:17 UTC
we've seen quite a few kernel memory space corruption reports with the nvidia driver,

*** This bug has been marked as a duplicate of bug 740602 ***


Note You need to log in before you can comment on or make changes to this bug.