Bug 740693 - control-center update has unsatified libnm-gtk.so.0 dependency
Summary: control-center update has unsatified libnm-gtk.so.0 dependency
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-22 23:54 UTC by Stan King
Modified: 2011-10-24 21:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-24 21:37:11 UTC


Attachments (Terms of Use)

Description Stan King 2011-09-22 23:54:04 UTC
Description of problem:

When processing today's updates to F16 Alpha, I received an error that control-center required libnm-gtk.so.0.  I've been unable to find where that dependency can be satisfied from.

Using yum's --skip-broken option let all the other updates proceed normally.

The suggested "rpm -Va --nofiles --nodigest" command did not produce any output.

For what it's worth, although I'm using the xfce environment, I use gnome-control-center to do the sound control functions unavailable with xfce, and it still seems to be working OK, even after this failed update.

Version-Release number of selected component (if applicable):

control-center.i686 1:3.1.92-1.fc16

How reproducible:

Every time, even after a "yum clean all".

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:

Error concerning lack of libnm-gtk.so.0.

Expected results:

A successful update of control-center.

Additional info:

The following is the output from the "yum update" command:

...
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package control-center.i686 1:3.1.91-1.fc16 will be updated
---> Package control-center.i686 1:3.1.92-1.fc16 will be an update
--> Processing Dependency: libnm-gtk.so.0 for package: 1:control-center-3.1.92-1.fc16.i686
---> Package control-center-filesystem.i686 1:3.1.91-1.fc16 will be updated
---> Package control-center-filesystem.i686 1:3.1.92-1.fc16 will be an update
--> Finished Dependency Resolution
Error: Package: 1:control-center-3.1.92-1.fc16.i686 (updates-testing)
           Requires: libnm-gtk.so.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 igor.redhat@gmail.com 2011-09-23 22:08:23 UTC
Same error here - happened on the first "yum upgrade" after the installation of F16 Alpha Live ISO

Comment 2 Andy Grimm 2011-10-04 15:57:16 UTC
FWIW, I worked around this with:

sudo yum update control-center --enablerepo updates-testing

which pulled in NetworkManager-gtk-0.9.1.90-3.git20110927.fc16.x86_64 to satisfy the dep.

Comment 3 Matthias Clasen 2011-10-24 21:37:11 UTC
I believe all involved updates are in stable now


Note You need to log in before you can comment on or make changes to this bug.