Bug 740713 - Copy From Source does not open the editor and update the content on page 2 or after.
Copy From Source does not open the editor and update the content on page 2 or...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.4-RC
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks: Zanata-1.4
  Show dependency treegraph
 
Reported: 2011-09-23 00:37 EDT by Ding-Yi Chen
Modified: 2011-10-28 03:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-09-23 00:37:42 EDT
Description of problem:
In translation editor, Clicking Copy form source on page 2 or after should 
1) open the editor for further editing
2) Update the translation to match the source
3) Display the updated content.

Current version only does 2) because clicking the corresponding editor cell shows the correct updated content, however, it failed to do 1 and 3.

This make the "copy from source" button look non-functional.

Version-Release number of selected component (if applicable):
Zanata version 1.4-alpha-2-SNAPSHOT (20110922-1647)

How reproducible:
Always


Steps to Reproduce:
1. Visit a document with multiple pages of translation, like Fedora Release Note (f13)->Desktop
2. Go to page 2
3. On row 1, press "Copy From Source"
  
Actual results:
The content actually updated, but the UI does not show the updated content.

Expected results:
The content actually updated, and UI shows the updated content, and cell editor open on row 1 for further editing.

Additional info:
Comment 1 Sean Flanigan 2011-09-23 00:40:18 EDT
This is bad, because Copy From Source is not supposed to save until the user (a) clicks Save, or (b) moves away from the editor.  Saving invisibly and automatically is not on.
Comment 2 Alex Eng 2011-09-25 19:14:14 EDT
Problem fixed in 1.4 branch.
Comment 3 Ding-Yi Chen 2011-09-25 21:00:13 EDT
VERIFIED with Zanata version 1.4-alpha-2-SNAPSHOT (20110926-1026)

Note You need to log in before you can comment on or make changes to this bug.